Visualizzazione risultati 1 fino 6 di 6
Like Tree1Likes
  • 1 Post By alemoppo

Discussione: .htaccess non funziona

  1. #1
    veronacityguide non è connesso Neofita
    Data registrazione
    11-03-2008
    Messaggi
    2

    Predefinito .htaccess non funziona

    Buongiorno a tutti,
    vorrei modificare il mio sito inserendo dei menu dinamici. Per far questo le pagine dal vecchio html avranno estensione php. Per non perdere indicizzazione vorrei però mantenere la vecchia url in html.
    Ho provato a modificare il file .htaccess senza successo.

    Questo il codice inserito
    Codice:
    <ifModule mod_rewrite.c>
    
    RewriteEngine On
    RewriteBase /
    
    RewriteRule ^/guide-verona/prova.html$ /guide-verona/prova.php
    però non succede niente.
    Ho provato anche a fare prove con redirect 301 tramite .htaccess ma anche qui niente. E' come se non vedesse proprio il file htaccess.
    Ho dato un'occhiata al forum ma non trovo nulla.
    Qualcuno sa dirmi se c'è qualcosa che debba attivare per farlo andare?
    Grazie mille

    Miki
    Ultima modifica di alemoppo : 02-03-2018 alle ore 17.15.02 Motivo: +tag [code]

  2. #2
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,035

    Predefinito

    Post editato, la soluzione proposta da alemoppo è quella giusta.
    Ultima modifica di darbula : 02-03-2018 alle ore 17.54.32

  3. #3
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,755

    Predefinito

    Se il tuo scopo è eseguire codice PHP su pagine con estensione .html, puoi semplicemente farlo aggiungendo questa riga all' .htaccess:
    Codice:
    AddType application/x-httpd-php .html
    Ciao!
    veronacityguide likes this.

  4. #4
    veronacityguide non è connesso Neofita
    Data registrazione
    11-03-2008
    Messaggi
    2

    Predefinito

    MITICO!!!!
    era esattamente quello che mi serviva.
    e funziona alla grande.
    Grazie
    Mik

  5. #5
    Data registrazione
    19-10-2019
    Messaggi
    8

    Predefinito

    Scusate ma sono molto inesperto e non riesco proprio a farla funzionare.

  6. #6
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,755

    Predefinito

    Citazione Originalmente inviato da FrancescoDiTardo Visualizza messaggio
    Scusate ma sono molto inesperto e non riesco proprio a farla funzionare.
    Continua pure nella tua discussione. Spiega meglio cosa non riesci a fare, e perché non vuoi utilizzare pagine con estensione .php

    Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •