Visualizzazione risultati 1 fino 6 di 6

Discussione: Il mio sito non si collega al Db

  1. #1
    marighettia non è connesso Neofita
    Data registrazione
    29-10-2003
    Messaggi
    5

    Predefinito Il mio sito non si collega al Db

    Buonasera, da questa mattina il mio sito, nei giorni passati funzionava senza problemi, restituisce un messaggio di errore quando cerca di fare una query sul DB mysql.
    Ho fatto alcune prove e sembrerebbe che le variabili non vengano passate da pagina a pagina.
    Potreste aiutarmi?

    Dalla pagina di login inserisco utenza e password e viene subito restituito l'errore

    http://marighettia.altervista.org/html/login.html

    Grazie in anticipo.
    Andrea
    Ultima modifica di marighettia : 29-03-2017 alle ore 21.40.53

  2. #2
    mzanella non è connesso AlterVistiano
    Data registrazione
    29-12-2015
    Messaggi
    862

    Predefinito

    Riporta il codice che stai utilizzando.

  3. #3
    marighettia non è connesso Neofita
    Data registrazione
    29-10-2003
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da mzanella Visualizza messaggio
    Riporta il codice che stai utilizzando.
    Ciao mzanella, grazie x aver risposto.
    Premetto che il sito è del 2003, ed è amatoriale, un giochino con alcuni amici quindi mi aspetto sia stra superato in quanto a codice. Spero però non mi costringa ad intervenire pesantemente sulla riscrittura. Comunque, ti allego il pezzo di chiamata e di ricezione, dove secondo me la variabile $stagione non viene intercettata.

    Pagina chiamante:
    ...form action="../php/LegaFantaMazzone.php" method="post" name="login"
    onsubmit="return check_login()">
    <input type="hidden" name="stagione" value=2016>
    <input type="hidden" name="log...
    ...

    Pagina chiamata:
    ...
    <?
    require("connect.php");

    //************************************************** **********
    //********* INSERIMENTO FORMAZIONI ***********************
    //************************************************** **********
    $sql99 = "SELECT max(giornata) as mgiornata
    from CALENDARIO_CK
    where stagione=$stagione
    and ck_giocata='S'";
    $ris99 = mysql_query($sql99) or die ("Select su MESSAGGI fallita");
    $riga99 = mysql_fetch_array($ris99);

    $mgiornata = $riga99["mgiornata"] + 1;
    .....

    La query va in errore perché la variabile $stagione è vuota...

    Ti ringrazio.
    Andrea

  4. #4
    mzanella non è connesso AlterVistiano
    Data registrazione
    29-12-2015
    Messaggi
    862

    Predefinito

    secondo me la variabile $stagione non viene intercettata.
    Sì, quasi certamente il problema è quello. L'accesso "diretto" ai valori passati tramite $_GET/$_POST è stato deprecato e poi disabilitato, per recuperare il valore usa:
    Codice PHP:
    $stagione $_POST['stagione'

  5. #5
    marighettia non è connesso Neofita
    Data registrazione
    29-10-2003
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da mzanella Visualizza messaggio
    Riporta il codice che stai utilizzando.
    Immaginavo di dover inserire ad inizio di ogni pagina queste valorizzazioni.
    Stasera provo.
    Per curiosità, è stato aggiornato il PHP in questi ultimi giorni per giustificare questa situazione?
    Grazie 1000, ti aggiorno sull'esito.
    Andrea

  6. #6
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,147

    Predefinito

    Citazione Originalmente inviato da marighettia Visualizza messaggio
    Per curiosità, è stato aggiornato il PHP in questi ultimi giorni per giustificare questa situazione?
    http://forum.it.altervista.org/novit...-new-post.html

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •