Visualizzazione risultati 1 fino 15 di 15

Discussione: Invio mail tramite form php

  1. #1
    Guest

    Predefinito Invio mail tramite form php

    Buongiorno a tutti e grazie in anticipo per il supporto.

    Ho creato un form in un pagina html per l'invio di un messaggio e il problema è che quando ricevo la mail, la ricevo senza i parametri richiesti e cioè "nome, email e messaggio".
    La cosa più assurda è che il codice funziona perché l'ho già provato in un altro form sempre caricato su altervista e li funziona tutto regolarmente.
    Per darvi qualche info in più. Laddove funzione è caricato su "nome.altervista.org/cartella/pagina.html", dove non funziona si trova nella prima pagina e cioè su "nome.altervista.org"

    Non posto il codice sia html che php perché come ho già detto il codice funziona e quindi credo che si tratti di un problema interno ad altervista.

    Grazie mille in anticipo

    Fabio

  2. #2
    L'avatar di saitfainder
    saitfainder non è connesso Sëniör Stäff
    Data registrazione
    06-12-2002
    Residenza
    Torino
    Messaggi
    8,715

    Predefinito

    Citazione Originalmente inviato da comunicazionect Visualizza messaggio
    Non posto il codice sia html che php perché come ho già detto il codice funziona e quindi credo che si tratti di un problema interno ad altervista.
    E sei sicuro che passi i valori giusti alla funzione mail?


    «È una mia peculiarità distorcere la verità e inventarne di nuove.»
    «I tuoi orientamenti hanno su di me un effetto prossimo allo zero.»


  3. #3
    fabiovergotti non è connesso Utente
    Data registrazione
    18-02-2013
    Messaggi
    249

    Predefinito

    Citazione Originalmente inviato da saitfainder Visualizza messaggio
    E sei sicuro che passi i valori giusti alla funzione mail?
    io ho lo stesso problema...o meglio uno molto simile....un codice COPIATO ED INCOLLATO da 2 siti miei entrambi hostati su altervista....la mail un uno viene inviata correttamente su l'altro non parte!

    comunicazionect per favore riesci a metterci qui il codice della pagina? in modo da cercare di capire dov'è l'errore?
    vedi qui se trovi qulcosa :)

    Fabio

  4. #4
    L'avatar di saitfainder
    saitfainder non è connesso Sëniör Stäff
    Data registrazione
    06-12-2002
    Residenza
    Torino
    Messaggi
    8,715

    Predefinito

    Se lo stesso codice lo usi su due siti e su uno non funziona le possibilità sono tre:
    * in un caso passi dei valori sbagliati alla funzione e di conseguenza non va
    * le mail inviate finiscono nello spam
    * stai mandando centinaia di mail al giorno e quindi te le blocchiamo


    «È una mia peculiarità distorcere la verità e inventarne di nuove.»
    «I tuoi orientamenti hanno su di me un effetto prossimo allo zero.»


  5. #5
    fabiovergotti non è connesso Utente
    Data registrazione
    18-02-2013
    Messaggi
    249

    Predefinito

    Citazione Originalmente inviato da saitfainder Visualizza messaggio
    Se lo stesso codice lo usi su due siti e su uno non funziona le possibilità sono tre:
    * in un caso passi dei valori sbagliati alla funzione e di conseguenza non va
    * le mail inviate finiscono nello spam
    * stai mandando centinaia di mail al giorno e quindi te le blocchiamo
    le variabili ho provato a stamparle tramiche echo e sono corrette :(
    le mail eccessive no...perchè il sito non è ancora pubbliuco quindi lo conosco solo io :/ la spam è vuota :/
    vedi qui: Invio mail alla registrazione
    Ultima modifica di fabiovergotti : 20-05-2014 alle ore 20.57.57

  6. #6
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    Che risultati dà questo test? Testare la funzionalità mail del proprio sito
    Gianluca

  7. #7
    fabiovergotti non è connesso Utente
    Data registrazione
    18-02-2013
    Messaggi
    249

    Predefinito

    Citazione Originalmente inviato da Gianluca Visualizza messaggio
    Che risultati dà questo test? Testare la funzionalità mail del proprio sito
    il test da risposta positiva...ma la mail non arriva

  8. #8
    fabiovergotti non è connesso Utente
    Data registrazione
    18-02-2013
    Messaggi
    249

    Predefinito

    ho provato a cambiare indirizzo mail...e li arriva...è possibile che dipenda da windows live?

  9. #9
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    È possibile che quel provider filtri temporaneamente l'email che invii, o la differisca, questo può capitare se hai mandato di recente molte email o comunque qualcuno le ha marcate come spam.
    Gianluca

  10. #10
    fabiovergotti non è connesso Utente
    Data registrazione
    18-02-2013
    Messaggi
    249

    Predefinito

    Citazione Originalmente inviato da Gianluca Visualizza messaggio
    È possibile che quel provider filtri temporaneamente l'email che invii, o la differisca, questo può capitare se hai mandato di recente molte email o comunque qualcuno le ha marcate come spam.
    ah ok...grazie mille :)

    per caso mi sai aiutare anche qui: Gallery

  11. #11
    Guest

    Predefinito

    Citazione Originalmente inviato da fabiovergotti Visualizza messaggio
    io ho lo stesso problema...o meglio uno molto simile....un codice COPIATO ED INCOLLATO da 2 siti miei entrambi hostati su altervista....la mail un uno viene inviata correttamente su l'altro non parte!

    comunicazionect per favore riesci a metterci qui il codice della pagina? in modo da cercare di capire dov'è l'errore?
    vedi qui se trovi qulcosa :)

    Fabio

    HTML
    <form role="form" action="send.php" method="post" class="center">
    <input name="nome" type="text" class="form-control" id="input_name" placeholder="Nome...">
    <input name="email" type="email" class="form-control" id="input_email" placeholder="Email...">
    <textarea name="messaggio" rows="3" class="form-control" id="input_message" placeholder="Messaggio..."></textarea>
    <button type="submit" class="btn btn-primary pull-right">Invia</button>
    </form>

    PHP

    <?php
    $indirizzo="lombardofabio@hotmail.com";
    {
    mail($indirizzo,"$nome ti inviato un messaggio dal tuo sito web" , "Questo è il suo indirizzo: $email" , "Questo è il suo messaggio: $messaggio");

    echo ("Invio riuscito correttamente");

    }
    ?>

    Ripeto che su un sito funziona, su quest'altro no.
    Esattamente mi manda una mail vuota tip questa:


    ...ti ha inviato un messaggio dal tuo sito web
    Questo è il suo messaggio:
    Questo è il suo indirizzo:

    senza però fornire ne l'email di chi ha inviato il messaggio, ne il messaggio. I campi sono vuoti

  12. #12
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    comunicazionect:

    prova questo: Testare la funzionalità mail del proprio sito sul sito in questione
    Gianluca

  13. #13
    Guest

    Predefinito

    Ciao e grazie per la risposta.
    Scusa ma non ho capito cosa devo fare con quello script.
    Ad ogni modo, io credo che tutto funzioni, perché la mail mi arriva. Solo che mi restituisce i campi vuoti

  14. #14
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    Ad ogni modo, io credo che tutto funzioni, perché la mail mi arriva. Solo che mi restituisce i campi vuoti
    Avevo frainteso. Non si tratta allora di un problema con l'invio email ma di codice.

    Probabilmente ti capita perché hai una versione php differente impostata su quell'account, con un valore di register_globals diverso.

    Usa $_POST['nome'] invece di $nome ecc ecc
    Gianluca

  15. #15
    Guest

    Predefinito

    Gianluca sei stato gentilissimo. Adesso funziona.
    Grazie Mille per il supporto e per il lavoro che fate in generale.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •