Visualizzazione risultati 1 fino 6 di 6

Discussione: aggiornare a PHP 5.3

  1. #1
    Guest

    Question aggiornare a PHP 5.3

    Su WordPress ho un plugin che vuole PHP 5.3 (Commenti Evolved per WordPress) ed mi è necessario visto che è un blog che parla di Google

    Ho aggiornato trammite lo swich PHP da php 5.2 a PHP 5.3 ma il plugin non funziona neanche disabilitando e reabilitanto, mi dice che è sempre 5.2.7 perché è da 10 minuti che fa la stessa storia.

    Poi perché siete così indietro? normalmente siamo su PHP 5.3/4/5 e c'è già in giro la versione 5.6 in prova.

  2. #2
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterGuru
    Data registrazione
    02-05-2007
    Messaggi
    1,039

    Predefinito

    ciao, tramite pannello di controllo altervista accedi a gestione file e alla cartella che contiene i file di wordpress che è la cartella /blog da li in alto clicca sul logo php 5 e attiva il php 5.3, non si puo aggiornare troppo velocemente le versioni di php sui server perche altrimenti molti applicativi web non funzionerebbero
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

  3. #3
    L'avatar di dreadnaut
    dreadnaut non è connesso Super Moderatore
    Data registrazione
    22-02-2004
    Messaggi
    5,950

    Predefinito

    Citazione Originalmente inviato da googleblogitalia Visualizza messaggio
    Poi perché siete così indietro? normalmente siamo su PHP 5.3/4/5 e c'è già in giro la versione 5.6 in prova.
    Già che le ho postate in un'altra discussione, dai un'occhiata alle statistiche delle versioni usate, con meno del 6% dei server con una versione superiore a 5.3
    chezDreadnaut
    "Un <BR/> è impuro, punto."
    "I <P>&nbsp;</P> non hanno diritto di esistere."

  4. #4
    Guest

    Predefinito

    Citazione Originalmente inviato da RedWebSite Visualizza messaggio
    ciao, tramite pannello di controllo altervista accedi a gestione file e alla cartella che contiene i file di wordpress che è la cartella /blog da li in alto clicca sul logo php 5 e attiva il php 5.3, non si puo aggiornare troppo velocemente le versioni di php sui server perche altrimenti molti applicativi web non funzionerebbero
    è già su PHP 5.3 dalle 14.00 ma ancora sul blog mi viene che è 5.2.17 non cambia niente.

    Citazione Originalmente inviato da dreadnaut
    Già che le ho postate in un'altra discussione, dai un'occhiata alle statistiche delle versioni usate, con meno del 6% dei server con una versione superiore a 5.3
    Vedo solo che se usate di default PHP 5.2 altervista è indietro

  5. #5
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    googleblogitalia:

    vedi php 5.2 perché tale è esplicitamente impostato nel folder /blog/, l'impostazione della versione php è infatti fatta per cartella, devi accedere nella gestione files alla cartella /blog/ e impostare anche lì php 5.3, o semplicemente togliere nell'.htaccess

    AddHandler av-php5 .php

    In modo che erediti l'impostazione di "/"

    Vedo solo che se usate di default PHP 5.2 altervista è indietro
    Se fino ad ora è stata proposta come default quella versione piuttosto che la 5.3 (comunque disponibile) ci sono delle ragioni precise, e stanno nel garantire il maggior livello di compatibilità e stabilità possibile per un servizio che ospita 2 milioni di siti con una varietà enorme di applicativi diversi installati, alcuni fatti in casa.

    php 5.3 sarà comunque default in autunno con la possibilità di attivare php 5.2 legacy per motivi di compatibilità.
    Gianluca

  6. #6
    Guest

    Thumbs up

    Aposto! Ottimo! Grazie ora funziona :)

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •