Visualizzazione risultati 1 fino 12 di 12

Discussione: problema audio

  1. #1
    L'avatar di CoD
    CoD
    CoD non è connesso Utente storico
    Data registrazione
    21-04-2003
    Messaggi
    2,451

    Predefinito problema audio

    Con il prezioso aiuto di numerone ho ricompilato il kernel.

    Ora pero' la scheda audio non da piu' segni di vita.

    Ho mandrake 9.2, kenrel 2.4.22-35
    La scheda audio e' una ADI AD1985 integrata sulla motherboard Asus P4P800

    Prima ottenevo l'errore:

    Sound Server Message:
    Can't set real-time scheduling priority.
    You need to run artswrapper as root or setuid root.
    This means that you will likely not be able to produce acceptable sounds (ie without clicks and breaks)


    seguito da:

    sound server suspended

    Cosi' ho fatto un po' di ricerche in rete, e facendo:
    chmod +s /usr/bin/artswrapper

    Ho eliminato il primo errore.

    Rimane il fatto che il server viene sospeso non appena kde parte.

    Ho cercato e ho visto che facendo lspcidrake -v | fgrep AUDIO ottengo:
    snd-intel8x0 : Intel Corp.|82801EB AC'97 Audio [MULTIMEDIA_AUDIO] (vendor:8086 device:24d5 subv:1043 subd:80f3)

    che e' poi il driver che ho impostato.

    Ho provato a ricompilare nuovamente il kernel dandogli il driver non come modulo, ma alla fine della compilazione mi da errore proprio sul driver audio dicendo qualcosa come missing binaries o simili.

    Come faccio a rimettere a posto il supporto audio?

    Vi prego aiutatemi!
    Collaboratore 332 della Free Software Foundation Europe
    Linux Registered User 354705
    Credo che moriro' il giorno che smettero' di imparare. Di sicuro smettero' di imparare il giorno che moriro'.

  2. #2
    Guest

    Predefinito

    Carica i moduli della scheda OLD

  3. #3
    L'avatar di CoD
    CoD
    CoD non è connesso Utente storico
    Data registrazione
    21-04-2003
    Messaggi
    2,451

    Predefinito

    Ok saro' scemo ma come faccio?

    Inoltre sei sicuro che siano i moduli? Qui mi dice che e' il server che viene sospeso.
    Collaboratore 332 della Free Software Foundation Europe
    Linux Registered User 354705
    Credo che moriro' il giorno che smettero' di imparare. Di sicuro smettero' di imparare il giorno che moriro'.

  4. #4
    Guest

    Predefinito

    Citazione Originalmente inviato da CoD
    Ok saro' scemo ma come faccio?
    Quando hai ricompilato il kernel hai specificato quali driver audio usare, in particolare avrai selezionato con una M quelli della tua scheda audio.

    1. controlla se quei moduli sono già caricati con il comando lsmod ; otterrai una lista di moduli caricati nel kernel con altre informazioni sull'utilizzo

    2. nel caso non fosse presente devi inserire il modulo giusto che trovi in:
    /lib/modules/tua_versione_del_kernel/la_directory_contenente_il_driver_audio
    il driver audio lo trovi sotto forma di file driver.o

    3. una volta trovato il file giusto ti basta fare insmod nomefile.o

  5. #5
    L'avatar di CoD
    CoD
    CoD non è connesso Utente storico
    Data registrazione
    21-04-2003
    Messaggi
    2,451

    Predefinito

    Bel problema.

    Il modulo c'e' eccome, assieme a tanti altri:
    Codice:
    ...
    snd-seq-oss            32000   0  (unused)
    snd-seq-midi-event      6080   0  [snd-seq-oss]
    snd-seq                42544   2  [snd-seq-oss snd-seq-midi-event]
    snd-pcm-oss            43652   0
    snd-mixer-oss          14200   0  [snd-pcm-oss]
    snd-intel8x0           22020   0
    snd-pcm                79588   0  [snd-pcm-oss snd-intel8x0]
    snd-timer              18436   0  [snd-seq snd-pcm]
    snd-ac97-codec         45752   0  [snd-intel8x0]
    snd-page-alloc          9044   0  [snd-intel8x0 snd-pcm]
    snd-mpu401-uart         4704   0  [snd-intel8x0]
    snd-rawmidi            17760   0  [snd-mpu401-uart]
    snd-seq-device          5832   0  [snd-seq-oss snd-seq snd-rawmidi]
    snd                    41412   0  [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
    soundcore               6340   0  [snd]
    ...
    Collaboratore 332 della Free Software Foundation Europe
    Linux Registered User 354705
    Credo che moriro' il giorno che smettero' di imparare. Di sicuro smettero' di imparare il giorno che moriro'.

  6. #6
    express non è connesso AlterVistiano
    Data registrazione
    08-08-2003
    Residenza
    Cagliari/Pisa
    Messaggi
    799

    Predefinito

    http://express.altervista.org
    Dato un lavoro, si possono scegliere due sole delle seguenti caratteristiche: veloce, economico, di qualità.
    Così capita che se un lavoro è veloce ed economico non sarà di qualità; se è veloce e di qualità non sarà economico; se è economico e di qualità non sarà veloce.

  7. #7
    L'avatar di CoD
    CoD
    CoD non è connesso Utente storico
    Data registrazione
    21-04-2003
    Messaggi
    2,451

    Predefinito

    Grazie me lo leggero per benino, ma temo che il problema sia del server arts e non del modulo.
    Collaboratore 332 della Free Software Foundation Europe
    Linux Registered User 354705
    Credo che moriro' il giorno che smettero' di imparare. Di sicuro smettero' di imparare il giorno che moriro'.

  8. #8
    Guest

    Predefinito

    a quanto sembra da quello che ti dice lsmod il driver è stato caricato correttamente :eyes:

    Puoi provare a vedere se il modulo del driver o il server arts ha fornito qualche messaggio di errore in fase di caricamento guardando l'output di dmesg con:

    dmesg | less

    PS: mi sembra di ricordare che anche io ho avuto grossi problemi con la mia scheda audio integrata intel con la Mandrake 9.2... Con la 10 official non dovrebbero esserci problemi. Tienilo presente nel caso in cui non riuscissi a cavarne un ragno dal buco :grin:

  9. #9
    L'avatar di CoD
    CoD
    CoD non è connesso Utente storico
    Data registrazione
    21-04-2003
    Messaggi
    2,451

    Predefinito

    Pero' con il kernel originale la mia scheda audio andava benissimo!

    Mi spieghi cosa devo cercare in dmesg? Me lo sono letto tutto ma non vedo messaggi relativi a 'arts' o a 'snd'.
    Collaboratore 332 della Free Software Foundation Europe
    Linux Registered User 354705
    Credo che moriro' il giorno che smettero' di imparare. Di sicuro smettero' di imparare il giorno che moriro'.

  10. #10
    Guest

    Predefinito

    dmesg non credo proprio ti possa dare informazioni su arts, cmq una scheda che utilizza il tuo stesso driver sono riuscito a farla funzionare senza problemi con il kernel 2.6 dove i driver alsa sono parte integrante del kernel, upgradare il kernel potrebbe risolvere la tua situazione , forse :/

  11. #11
    L'avatar di CoD
    CoD
    CoD non è connesso Utente storico
    Data registrazione
    21-04-2003
    Messaggi
    2,451

    Predefinito

    Ma... e' proprio perche' ho upgradato il kernel che si e' verificata questa situazione!!!!!!

    Con il 2.4.22-6 non avevo problemi. Ho ricompilato il 2.4.22-35 e sono incasinato!
    Collaboratore 332 della Free Software Foundation Europe
    Linux Registered User 354705
    Credo che moriro' il giorno che smettero' di imparare. Di sicuro smettero' di imparare il giorno che moriro'.

  12. #12
    Guest

    Predefinito

    Ho installato ieri una distro Linux Debian Sarge su un portatile con una scheda audio integrata simile alla tua... Stessi problemi :?????:

    O meglio... la scheda la riconosce e il mixer di X viene caricato correttamente ma non emette alcun suono.

    Io ho risolto usando una versione di kernel 2.4.26 o anche uno della serie 2.6.x. Ho ancora qualche problema con il sequencer ma prob perché ieri non avevo più voglia di dedicargli tempo. :eyes:

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •