Visualizzazione risultati 1 fino 5 di 5

Discussione: banner non visualizzati con errore JS

  1. #1
    baubag non è connesso Neofita
    Data registrazione
    19-02-2021
    Messaggi
    2

    Predefinito banner non visualizzati con errore JS

    Salve
    ho ricopiato lo script del banner nella pagina web però i banner non vengono visualizzati e nella console di js compare il seguente errore..

    Uncaught (in promise) Error: __tcfapi function missing
    at ?ref=baubag.altervista.org%2Fbaubag_site%2Flocaliz za&r=1616667564535:515
    at new Promise (<anonymous>)
    at ?ref=baubag.altervista.org%2Fbaubag_site%2Flocaliz za&r=1616667564535:513
    at async Promise.all (index 0)

    Qualche idea?

  2. #2
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    2,001

    Predefinito

    Salve,
    accedendo al sito, si vede la pagina di presentazione base dell'AlterSito.
    Sta usando un CMS in una sottocartella?
    Ha provato con altri browser e/o dispositivi?

    Crei una pagina di prova con solo il codice del banner, per verificare se il problema non dipende da altro. Quindi riporti qui il link di tale pagina.

    Cordiali saluti.

  3. #3
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,661

    Predefinito

    Come indicato nella pagina in cui hai trovato i codici delle pubblicità, è necessario che sia presente una CMP TCFv2 in pagina per permettere l'erogazione delle pubblicità. Vedi anche http://it.help.altervista.org/w/Erog...icitaria_e_TCF
    Hai inserito una CMP nella pagina in questione? Puoi riportarne l'indirizzo in modo da poter verificare?

  4. #4
    baubag non è connesso Neofita
    Data registrazione
    19-02-2021
    Messaggi
    2

    Predefinito

    Salve
    Si sto usando un CMS in una sottocartella però anche se creo una pagina di prova (come da Lei consigliato) JS restituisce lo stesso errore (sia con Chrome che con Microsoft Edge).
    La pagina è: https://baubag.altervista.org/banner.html

    Cosa sbaglio?

    Grazie

  5. #5
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    2,001

    Predefinito

    Nel file di prova, come giustamente ha fatto presente karl94 (#3), deve aggiungere anche il codice della policy per dare il conseso, altrimenti il banner non si vede anche nel caso che sia erogato correttamente.

    Cordiali saluti

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •