Visualizzazione risultati 1 fino 8 di 8
Like Tree2Likes
  • 2 Post By RedWebSite

Discussione: Cambio Cartella: Errore 404 e Altro

  1. #1
    dragonsword non è connesso Neofita
    Data registrazione
    27-05-2020
    Messaggi
    5

    Predefinito Cambio Cartella: Errore 404 e Altro

    Antefatto

    Ho trasferito tutti i files da una cartella chiamata "site" alla directory principale. Compiuta l'operazione tutti i menu e le voci di menu del sito sono saltate, con errore 404, tutte eccetto "Home", cioè quella con la home assegnata con stellina dal menù joomla. Sicuramente se rimuovessi la stellina salterebbe anche quello. Oltre questo si è generato un altra cosa molto fastidiosa. All'interno della gestione di altervista, per la precisione in bacheca, sotto il tasto "gestione file" si trova il tasto Joomla. Nel secondo i link sono errati, per capire meglio osservate le immagini di seguito:



    Quando entro, e sono in bacheca come vedete nell'immagine, osservo joomla 3. Se clicco su "visualizza", invece che andare nell'home del mio sito, compare questo:



    e il link di questa schermata è http://dragonsword.altervista.org/site/ ...ovvero, risponde ancora a quando avevo il sito dentro questa cartella. E questo succede anche se clicco su "visualizza" dalla schermata della bacheca, invece se vado su "Accedi" invece di andare al login dell'amministrazione giungla mi va qui:



    e il link è questo: http://dragonsword.altervista.org/site/administrator/

    Ultimo ma importante fatto ho provato a tornare sui miei passi, ho provato a rifare la cartella "site" e rimetterci il sito, ma a quel punto mi dava il seguente errore quando cliccavo sulla pagina dell'home più qualche altro problema sparso. L'errore era questo, lo stesso sopra, in qualche la situazione si capovolgeva, cioè a quel punto solo la home assegnata saltava e il resto si vedeva:

    setStart($startTime, $startMem)->mark('afterLoad') : null; // Instantiate the application. $app = JFactory::getApplication('site'); // Execute the application. $app->execute();

    ora devo mollare tutto per aver cercato di migrare da una cartella alla directory?...vi prego aiutatemi ho lavorato tanto
    Ultima modifica di dragonsword : 25-07-2020 alle ore 10.57.20

  2. #2
    GraphOGLRisorse è connesso ora AlterVistiano
    Data registrazione
    14-02-2015
    Messaggi
    902

    Predefinito

    Salve,
    provando con http://dragonsword.altervista.org/ vedo correttamente solo la home ma non carica le altre pagine, come menzionato da lei.

    Lei menzionava la cartella site, ma in questo percorso http://dragonsword.altervista.org/site/administrator/, fariferimento ad administrator. Cosa c'era dentro che è andato perso?

    Solitamete con i CMS, non si fa di spostare le pagine del sito dal punto dove sono state create. Comunque prima di fare cose simili, sabbe bene fare sempre un backup.

    Si ricordi anche di aggiornare la cache del browser tra una prova e l'altra, al fine di evitare falsi risultati.

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 25-07-2020 alle ore 14.34.27

  3. #3
    dragonsword non è connesso Neofita
    Data registrazione
    27-05-2020
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    Salve,
    provando con http://dragonsword.altervista.org/ vedo correttamente solo la home ma non carica le altre pagine, come menzionato da lei.

    Lei menzionava la cartella site, ma in questo percorso http://dragonsword.altervista.org/site/administrator/, fariferimento ad administrator. Cosa c'era dentro che è andato perso?

    Solitamete con i CMS, non si fa di spostare le pagine del sito dal punto dove sono state create. Comunque prima di fare cose simili, sabbe bene fare sempre un backup.

    Si ricordi anche di aggiornare la cache del browser tra una prova e l'altra, al fine di evitare falsi risultati.

    Cordiali saluti.
    Gentilissimo signore
    innanzitutto, grazie :)
    in secondo luogo, è esatto, è rimasto quel percorso desueto, il sito non ha perduto nulla ma la cartella "site"è vuota perchè ho messo tutto nella directory principale, ma non capisco come fare per impostare il percorso giusto

  4. #4
    GraphOGLRisorse è connesso ora AlterVistiano
    Data registrazione
    14-02-2015
    Messaggi
    902

    Predefinito

    E' probabile che le la index usi dei percorsi relativi, quindi, se le pagine del sito sono tutte nell' area principale(root), dovrebbe bastare modifcare quei link da gestione risorse. Eventualmente, se trova difficoltà con i percorsi relativi, li sostituisca con quelli assoluti.

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 25-07-2020 alle ore 15.59.07

  5. #5
    dragonsword non è connesso Neofita
    Data registrazione
    27-05-2020
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    E' probabile che le la index usi dei percorsi relativi, quindi, se le pagine del sito sono tutte nell' area principale(root), dovrebbe bastare modifcare quei link da gestione risorse. Eventualmente, se trova difficoltà con i percorsi relativi, li sostituisca con quelli assoluti.

    Cordiali saluti.
    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    E' probabile che le la index usi dei percorsi relativi, quindi, se le pagine del sito sono tutte nell' area principale(root), dovrebbe bastare modifcare quei link da gestione risorse. Eventualmente, se trova difficoltà con i percorsi relativi, li sostituisca con quelli assoluti.

    Cordiali saluti.
    magari. Purtroppo no signore
    come le dicevo, anche da questo punto:

    Guardando l'immagine:
    perfino da questo punto,
    -cliccando su accedi mi da questo: http://dragonsword.altervista.org/site/administrator/
    -cliccando invece su visualizza mi da questo: http://dragonsword.altervista.org/site/

    come faccio a correggere quella regola?...mi potrebbe fare qualcue esempio di percorso relativo e la giusta dicitura nel caso il sito fosse nel "root"?...(non si sa mai potrebbe servire) onestamente c'è modo di risolvere?...se contattassi altervista e chiedessi un loro intervento?

  6. #6
    GraphOGLRisorse è connesso ora AlterVistiano
    Data registrazione
    14-02-2015
    Messaggi
    902

    Predefinito

    Sccusi, mi era sfuggitto che il link con administrator e ralativo a gestione risorse.

    I percorsi relativi si presentano in modo simile a questo: ../../pagina.html
    I percorsi assoluti si presentano in modo simile a questo: http://sito.altervista.org/cartella1...a2/pagina.html

    Se riesce ad accerere via ftp, può copiarsi i file in locale e modificarli, quindi poi ricaricarli sostituendoli.

    Lo staff di AlterVista, generalmete lo si contatta qui sul forum. Se ha urgenza, può inviare un messaggio privato ad alemoppo.

    Edit:
    Ho fatto una prova da http://dragonsword.altervista.org/site/ e adesso la home viene caricata(un pò più lentamente) e da qui, anche le altre pagine.

    Da qui http://dragonsword.altervista.org/, adesso appare la pagina di quando ci si è appena registrati.

    E' riuscito per caso a riaccedere al pannello di controllo?

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 25-07-2020 alle ore 17.52.36

  7. #7
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterGuru
    Data registrazione
    02-05-2007
    Messaggi
    1,038

    Predefinito

    Ciao, una volta spostato joomla, cioè tutti i files, dalla cartella site alla root principale bisogna semplicemente modificare il file configuration.php in questo modo:

    cercare
    public $tmp_path = ' e togliere /site
    cercare
    public $log_path = ' e togliere /site


    poi sul file htaccess modificare Rewritebase/site e togliere site
    Ultima modifica di RedWebSite : 25-07-2020 alle ore 22.25.34
    alemoppo and GraphOGLRisorse like this.
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

  8. #8
    dragonsword non è connesso Neofita
    Data registrazione
    27-05-2020
    Messaggi
    5

    Predefinito

    Scusate il ritardo, nulla ho comprato il back up e tornato al 19 luglio prima di leggere i vostri messaggi. Comunque proverò questi suggerimenti, vi ringrazio molto

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •