Visualizzazione risultati 1 fino 11 di 11

Discussione: joomla e https

  1. #1
    L'avatar di loppaworks
    loppaworks non è connesso Neofita
    Data registrazione
    05-04-2016
    Residenza
    ☣ Town of the Dead
    Messaggi
    5

    Predefinito joomla e https

    Salve, perchè rimane un sito non sicuro? http://www.loppaworks.altervista.org/portale/

    malgrado io abbia confermato tramite telefono una connessione sicura

  2. #2
    darbula è connesso ora AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,057

    Predefinito

    Citazione Originalmente inviato da loppaworks Visualizza messaggio
    Salve, perchè rimane un sito non sicuro? http://www.loppaworks.altervista.org/portale/

    malgrado io abbia confermato tramite telefono una connessione sicura
    La domanda corretta è come abilitare https in joomla?
    1)Attivare CloudFlare
    2)Attivare https (servizio offerto da CloudFlare)
    3)A seconda dell'applicazione si deve intervenire manualmente alla modifica di uno o più file..
    Eccoti un esempio per joomla originale (non so se quella che fornisce altervista abbia un comando per abilitare https dentro l'applicazione).
    Sito non protetto
    #Nota che quando usi http invece di https è ovvio che non sarà un sito protetto, mentre se usi https nella barra del browser e vedi cmq sito non sicuro, c'è qualche link in http (ovviamente se nella barra del browser vediamo https i link in http saranno quelli che compongono la pagina in questione.. Ad esempio CSS,JavaScript, immagini ecc)... Vai in gestisci CloudFlare e abilita la modalità di sviluppo (libera temporaneamente la cache di CloudFlare)... Non faresti male se vuoti tutte le altre cache (dentro l'applicativo in uso e nel tuo browser)
    Ultima modifica di darbula : 16-11-2017 alle ore 15.33.10 Motivo: Aggiunta chiarezza sito non sicuro

  3. #3
    L'avatar di loppaworks
    loppaworks non è connesso Neofita
    Data registrazione
    05-04-2016
    Residenza
    ☣ Town of the Dead
    Messaggi
    5

    Predefinito

    CloudFlare l'ho attivato e pure il servizio https confermato tramite l'attivazione telefonica.

    Cosa intendi per "A seconda dell'applicazione si deve intervenire manualmente alla modifica di uno o più file.."?

    #Nota che quando usi http invece di https è ovvio che non sarà un sito protetto, mentre se usi https nella barra del browser e vedi cmq sito non sicuro, c'è qualche link in http... Vai in gestisci CloudFlare e abilita la modalità di sviluppo (libera temporaneamente la cache di CloudFlare)... Non faresti male se vuoti tutte le altre cache (dentro l'applicativo in uso e nel tuo browser)
    Fatto, ma il problema rimane

    Ora che noto bene, anche il forum di altervista è non sicuro

  4. #4
    darbula è connesso ora AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,057

    Predefinito

    Oltre a leggere il mio messaggio clicca e leggi l'altro post :)
    Per la seconda volta riposto il link Sito non protetto
    Ultima modifica di darbula : 16-11-2017 alle ore 15.41.34 Motivo: Aggiunto link

  5. #5
    L'avatar di loppaworks
    loppaworks non è connesso Neofita
    Data registrazione
    05-04-2016
    Residenza
    ☣ Town of the Dead
    Messaggi
    5

    Predefinito

    Ok ora il dominio https è registrato su tutte le pagine e funzionante, però mi da sempre conflitti con qualcosa... come faccio a identificare nello specifico i file o i plugin che danno problemi?

  6. #6
    darbula è connesso ora AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,057

    Predefinito

    Citazione Originalmente inviato da loppaworks Visualizza messaggio
    Ok ora il dominio https è registrato su tutte le pagine e funzionante, però mi da sempre conflitti con qualcosa... come faccio a identificare nello specifico i file o i plugin che danno problemi?
    È una richiesta che non posso soddisfare perché non uso joomla ma quanto meno posta il link con il problema .. Cmq. Se il difetto è un link http che compone la pagina basta visualizzare il sorgente e così si capisce da cosa è dovuto il problema..
    EDIT devi anche vuotare le cache di joomla e del tuo browser.
    Ultima modifica di darbula : 17-11-2017 alle ore 11.53.45

  7. #7
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterGuru
    Data registrazione
    02-05-2007
    Messaggi
    1,002

    Predefinito

    Ciao, molto probabilmente hai chiamate esterne in http e non in https, devi vedere quali http hai inserito e devi modificarli in https!
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

  8. #8
    L'avatar di loppaworks
    loppaworks non è connesso Neofita
    Data registrazione
    05-04-2016
    Residenza
    ☣ Town of the Dead
    Messaggi
    5

    Predefinito

    Come faccio a modificarli in https se sono file esterni al sito?

  9. #9
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterGuru
    Data registrazione
    02-05-2007
    Messaggi
    1,002

    Predefinito

    se sono file esterni dipende da come li hai inseriti, ma comunque la risorsa esterna deve essere "servita" in https altrimenti non verrà caricata!

    EDit: ad esempio queste sono alcune risorse esterne che hai inserito nel tuo sito senza il protocollo https
    Codice:
    <img src="http://www.gamasutra.com/db_area/images/news/2015/Mar/239486/Itchio%20Logo.jpg" width="32" height="32" /></a>
    
    <a title="Indiedb" href="http://www.indiedb.com/members/loppaworks" target="_blank" rel="alternate noopener noreferrer">
    
    <img src="http://media.indiedb.com/images/global/indiedb.png" alt="Town of the Dead" width="32" height="32" /></a> 
    
    <a title="RPG2S" href="http://www.rpg2s.net/forum/index.php/user/1782-loppa/" target="_blank" rel="alternate noopener noreferrer">
    
    <img src="http://i65.tinypic.com/2dqk46u.jpg" width="32" height="32" /></a>
    
    <a title="Makerando" href="http://www.makerando.com/forum/profile/100-loppa/" target="_blank" rel="alternate noopener noreferrer">
    
    <img src="http://i67.tinypic.com/2a671cp.jpg" width="32" height="32" /></a>
    devi controllare quali di quei domini usa il protocollo https e modificarlo nel tuo codice
    Ultima modifica di RedWebSite : 17-11-2017 alle ore 13.50.47
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

  10. #10
    L'avatar di loppaworks
    loppaworks non è connesso Neofita
    Data registrazione
    05-04-2016
    Residenza
    ☣ Town of the Dead
    Messaggi
    5

    Predefinito

    Bah a me sinceramente, dava solo fastidio quel simbolo accanto all'url e trovo assurdo dover fare tutti questi passaggi per rimuoverlo.
    Ho provato a modificare quelle risorse, a occultare il modulo e aggiornando tutto e cancellando la cache ma il simbolo non sicuro, rimane e onestamente, è pesante, cercare ogni singolo file che da il conflitto.

    Scusate le rogne ma a questo punto preferisco evitare, lascio integrati i contenuti delle altre pagine web non sicure così posso caricare anche script esterni senza problemi.

  11. #11
    darbula è connesso ora AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,057

    Predefinito

    Citazione Originalmente inviato da loppaworks Visualizza messaggio
    Bah a me sinceramente, dava solo fastidio quel simbolo accanto all'url e trovo assurdo dover fare tutti questi passaggi per rimuoverlo.
    Ho provato a modificare quelle risorse, a occultare il modulo e aggiornando tutto e cancellando la cache ma il simbolo non sicuro, rimane e onestamente, è pesante, cercare ogni singolo file che da il conflitto.

    Scusate le rogne ma a questo punto preferisco evitare, lascio integrati i contenuti delle altre pagine web non sicure così posso caricare anche script esterni senza problemi.
    Purtroppo la sicurezza non è assurda... Se ci impieghi tempo sei sicuro... nessun hosting può fornirti la pappa pronta riguardo ai tuoi link esterni... Da adesso in poi utilizza solo servizi che hanno http/https e poi li puoi usare senza protocollo iniziale "//dominio.com/file.html" nel href :)
    Cmq. Attualmente non hai modificato tutti i link http
    Ultima modifica di darbula : 17-11-2017 alle ore 19.49.22

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •