Visualizzazione risultati 1 fino 5 di 5

Discussione: Joomla! e Problemi HTTPS

  1. #1
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterVistiano
    Data registrazione
    02-05-2007
    Messaggi
    980

    Exclamation Joomla! e Problemi HTTPS

    Ciao a tutti, un pò di tempo fà ho attivato e configurato senza problemi il servizio HTTPS su uno dei siti che gestisco, ieri ho scritto una guida su alterjoomla sulla procedura da seguire per attivare il servizio e configurare il CMS e mentre scrivevo la guida, per non dimenticarmi di scrivere qualcosa pur non potendolo tenere attivo ho i banner inseriti, ripetevo l'attivazione del servizio e configurazione del cms su alterjoomla.

    Ma ho riscontrato un pò di problemi, anche nel pannello di controllo di joomla! non tutti i link vengono richiamati in https, ho attivato l'opzione su cloudflare e provato anche ad inserire la regola sul file htaccess, ma la cosa peggiore è che alcune estensioni, ad esempio akeeba backup, non funzionano e, peggio del peggio, non si visualizza l'editor, questo accade su alterjoomla e sul mio sito, account da cui scrivo, siccome le uniche differenze sono:

    1. i banner, ma non dovrebbero creare questo problema nel back-end
    2. il server, il sito su cui non ho problemi si trova sul server 307 metri gli altri 2 sul server 311.


    vi chiedo gentilmente se potete fare dei test? perche se le config. dei 2 server sono identiche o non ci sono problemi sul 311 vorrà dire che devo sbattere ancora un pò la testa su joomla per capire qual'è il problema! scusate la lungaggine grazie mille
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

  2. #2
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,119

    Predefinito

    Puoi riportare il nome dell'account in cui funziona senza problemi?
    Quali sono le modifiche al file .htaccess che hai apportato?
    Nella pagina dell'editor cosa visualizzi di preciso? Cosa riporta la console degli errori del browser?
    Quali sono esempi di collegamenti che rimangono in HTTP?

  3. #3
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterVistiano
    Data registrazione
    02-05-2007
    Messaggi
    980

    Predefinito

    Ciao karl questo è il sito dove HTTPS funziona perfettamente
    Codice:
    palasanpietro.altervista.org
    se ti colleghi anche senza inserire il collegamento https vedi che si visualizza automaticamente in https.

    La modifica al file htaccess è questa
    Codice:
    RewriteCond %{HTTP_HOST} !^palasanpietro.altervista.org$ [NC]
    RewriteRule ^(.*)$ https://palasanpietro.altervista.org/$1 [L,R=301]
    ma immagino che attivando l'opzione Automatic HTTPS Rewrites su cloudflare non ci sia bisogno di questa regola.

    Nel backend dei siti su cui ho problemi ci sono anche voci di menu non inviate in https, ti aggiungo parte di codice.
    Codice:
    <script>
    var plg_quickicon_joomlaupdate_url = 'http://redwebsite.altervista.org/administrator/index.php?option=com_joomlaupdate';
    var plg_quickicon_joomlaupdate_ajax_url = 'http://redwebsite.altervista.org/administrator/index.php?option=com_installer&view=update&task=update.ajax*******************';
    var plg_quickicon_jupdatecheck_jversion = '3.6.5'
    var plg_quickicon_joomlaupdate_text = {"UPTODATE" : "Joomla! è aggiornato.","UPDATEFOUND": "Joomla! <span class=\'label label-important\'>%s</span>, Aggiorna adesso!","UPDATEFOUND_MESSAGE": "Joomla! <span class=\'label label-important\'>%s</span> è disponibile:","UPDATEFOUND_BUTTON": "Aggiorna adesso","ERROR": "Verifica versione Joomla! fallita...",};
    var plg_quickicon_joomlaupdate_img = {"UPTODATE" : "/administrator/templates/isis/images/header/icon-48-jupdate-uptodate.png","UPDATEFOUND": "/administrator/templates/isis/images/header/icon-48-jupdate-updatefound.png","ERROR": "/administrator/templates/isis/images/header/icon-48-deny.png",};
    var plg_quickicon_extensionupdate_url = 'http://redwebsite.altervista.org/administrator/index.php?option=com_installer&view=update&task=update.find*******************';
    var plg_quickicon_extensionupdate_ajax_url = 'http://redwebsite.altervista.org/administrator/index.php?option=com_installer&view=update&task=update.ajax&02c8c969624ceba2cebf17864a782fd7=1';
    var plg_quickicon_extensionupdate_text = {"UPTODATE" : "Tutte le estensioni sono aggiornate","UPDATEFOUND": "Aggiornamenti disponibili! <span class=\'label label-important\'>%s</span>","UPDATEFOUND_MESSAGE": "Disponibile(i) <span class=\'label label-important\'>%s</span> aggiornamento(i) di estensioni:","UPDATEFOUND_BUTTON": "Vedi aggiornamenti","ERROR": "Verifica estensioni fallita...",};
    jQuery(function($){ $(".hasTooltip").tooltip({"html": true,"container": "body"}); });
    Aggiungo, penso sia importante, che quando è attivo HTTPS nel configuration di joomla non si riesce ad accedere, ho dovuto disattivare impostando a 0 accedere e riattivare

    Nella pagina dove deve esserci l'editor non si viasualizza proprio nulla nemmeno il campo i cui si deve digitare e non soltanto i vari tasti dell'editor (imm allegata), se hai l'accesso ai db puoi crearti un account super admin o se vuoi ti fornisco io un accesso senza problemi, Grazie mille!!

    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

  4. #4
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,119

    Predefinito

    Citazione Originalmente inviato da RedWebSite Visualizza messaggio
    La modifica al file htaccess è questa
    Codice:
    RewriteCond %{HTTP_HOST} !^palasanpietro.altervista.org$ [NC]
    RewriteRule ^(.*)$ https://palasanpietro.altervista.org/$1 [L,R=301]
    Questa non dovrebbe essere necessaria se Joomla funziona correttamente: si occupa lui del reindirizzamento in caso di visualizzazione mediante HTTP.
    Ad ogni modo io consiglierei piuttosto di attivare l'HSTS nelle impostazioni di CloudFlare (leggi comunque con attenzione come funziona, altrimenti potresti rischiare di non riuscire più ad accedere)
    Citazione Originalmente inviato da RedWebSite Visualizza messaggio
    ma immagino che attivando l'opzione Automatic HTTPS Rewrites su cloudflare non ci sia bisogno di questa regola.
    No, è una cosa differente. L'Automatic HTTPS Rewrites serve a correggere nel codice HTML (e forse anche in alcuni casi nel codice JavaScript e CSS, non ho verificato) eventuali URL HTTP, convertendoli da HTTP ad HTTPS nel caso la pagina venga distribuita mediante HTTPS. Per evitare il problema del mixed content.
    È comunque un'opzione da attivare solo proprio non si ha altra scelta, io sconsiglio fortemente di tenerla attiva, se non all'inizio per avere HTTPS in fretta se non si riesce a risolvere il problema del mixed content.
    Hai l'Automatic HTTPS Rewrites attivo solo su palasanpietro? Su redwebsite è attivo?
    Citazione Originalmente inviato da RedWebSite Visualizza messaggio
    ti fornisco io un accesso senza problemi, Grazie mille!!
    Non dovrebbe servire alcun accesso, non preoccuparti.

  5. #5
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterVistiano
    Data registrazione
    02-05-2007
    Messaggi
    980

    Predefinito

    Ciao Karl
    Citazione Originalmente inviato da karl94 Visualizza messaggio
    Ad ogni modo io consiglierei piuttosto di attivare l'HSTS nelle impostazioni di CloudFlare (leggi comunque con attenzione come funziona, altrimenti potresti rischiare di non riuscire più ad accedere)
    Provato niente da fare, anche attivando le varie opzioni

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    Hai l'Automatic HTTPS Rewrites attivo solo su palasanpietro? Su redwebsite è attivo?
    si è attivo su palas. ed anche su red ho provato sia attivo che disattivo, ho provato anche ad attivare Authenticated Origin Pulls, che non so cosa sia ma niente, comunque lascio attivo il certificato oggi anche se mi blocca i banner cosi se puoi dai uno sguardo, grazie ciao

    P.S. ho provato anche a cambiare il file htaccess per vedere se magari sopra ho qualche regola che gli da noia, ma niente...!!

    Ogni volta ho svuotato le cache joomla/cloudflare
    Ultima modifica di RedWebSite : 27-02-2017 alle ore 14.36.56
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •