Visualizzazione risultati 1 fino 7 di 7

Discussione: joomla 3.2 errore verifica aggiornamenti backend

  1. #1
    mrxpromotion non è connesso Neofita
    Data registrazione
    29-06-2009
    Messaggi
    4

    Predefinito joomla 3.2 errore verifica aggiornamenti backend

    salve, come da oggetto ho alcuni errori nel backend..
    inanzitutto io ho creato un sito in joomla3.2 in altro server, poi l'ho trasferito su altervista via ftp (filezilla non mi ha scritto di file non trasferiti).
    ho poi provveduto a trasferire il db.. e fin qui tutto ok..
    da front-end si può lavorare tranquillamente, invio articoli, mail dalla pagina contattaci,.., stesso dicasi per il backend ad eccezione di alcune importanti cose:
    1-sistema>pannello di controllo - nella colonna sx in basso, sia la verifica joomla che le estensioni falliscono.
    2-componenti>joomla update - ho questo errore: Si è verificato un errore. 0 No URL set!
    3-estensioni>gestione estensioni- ho questo errore: Si è verificato un errore. 500 View non trovato [name, type, prefix]: install, html, installerView
    4-accedendo agli articoli mi ritrovo questo errore: JFolder: :folder: Il percorso non è una cartella. Percorso: /membri/mrxpromotion/components/com_jce/editor/tiny_mce/plugins che ho risolto rimettendo tinymce.

    il percorso log e tmp dovrebbe essere ok: /membri/mrxpromotion/logs e /membri/mrxpromotion/logs (ho anche provato "membri" con "membri2")
    di fatto tutto il resto funziona bene, sono entrato in tutti i componenti e tutti i moduli.. tutto funziona bene, però non posso nè installare nè disinstallare perchè non posso andare in gestione estensioni.

    nel forum ho già trovato le indicazioni per aggioranre il php (che ho fatto), poi ho aggiornato il .htaccess seguendo le indicazioni: importare sito Joomla 3.x su altervista

    non ho abilitato innoDB, è strettamente necessario o è solo un'aggiunta per un migliore funzionamento? risolvo sicuramente comprandolo?

    grazie, ciao.

  2. #2
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterGuru
    Data registrazione
    02-05-2007
    Messaggi
    1,038

    Predefinito

    ciao, ti consiglio di abilitare innoDB per un corretto funzionamento di joomla 3, per quanto rigurada gli errori di aggiornamento devi modificare o eliminare il file
    Codice:
    /libraries/joomla/http/transport/curl.php
    per uteriori info a riguardo leggi questo topic ti ricordo che devi anche abilitare la connessione server to server dal pannello di controllo altervista
    Ultima modifica di RedWebSite : 09-12-2013 alle ore 14.07.32
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

  3. #3
    mrxpromotion non è connesso Neofita
    Data registrazione
    29-06-2009
    Messaggi
    4

    Predefinito

    ciao redweb, grazie per la pronta risposta.

    eliminato il file "curl.php" (immagino che dopo eventuale aggiornamento lo dovrò rieliminare?)
    ora dal pannello vedo che l'aggiornamento viene "pescato" correttamente.. naturalmente non posso accedervi per il problema già esposto nel primo post (punti 2 e 3).
    aspetto quindi il giorno 11 con l'attivazione di "innodb" (acquistato) e del "server to server" (già mandato sms) per vedere se la situazione si risolve.

    grazie, ciao.

  4. #4
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterGuru
    Data registrazione
    02-05-2007
    Messaggi
    1,038

    Predefinito

    di niente figurati, si ad ogni aggiornamento devi rimuovere nuovamente il file curl.php, joomla 3 richiede InnoDB e non è opzionale come puoi vedere qui, quindi appena ti si attiva dovresti rolvere i problemi rimasti ciao
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

  5. #5
    mrxpromotion non è connesso Neofita
    Data registrazione
    29-06-2009
    Messaggi
    4

    Predefinito

    ciao Redweb,
    ho visto che è stato attivato "innodb", però permangono i problemi relativi al punto 3 e 4 del primo post. Il problema n.4, seppur ho questo errore/avviso, pare che jce faccia lo stesso il suo lavoro, sia da backend che front-end.. il punto 3 però è per me un bel problema perchè non posso fare installazioni ne disistallare.
    ho riscontrato anche un nuovo problema (ma penso ci sia sempre stato), ovvero anche il componente "icagenda" non funziona e mi riporta questo errore: Fatal error: Call to a member function getLabel() on a non-object in /membri/mrxpromotion/administrator/components/com_icagenda/views/mail/tmpl/edit.php on line 65
    però da front-end funziona perfettamente, mi era venuto il dubbio che seppur filezilla non mi aveva dato errori, qualche file si fosse perso, ma a questo punto, neppure da front-end dovrebbe funzionare, invece funzia.

    ho passato componenti,plugin e moduli ad uno ad uno, da backend, per vedere se la pagina si apre e se si possono configurare, non ho riscontrato altri problemi oltre quelli già citati.

    sai darmi qualche altra indicazione per risolvere ?
    grazie, ciao.

  6. #6
    mrxpromotion non è connesso Neofita
    Data registrazione
    29-06-2009
    Messaggi
    4

    Predefinito

    ciao redweb,
    nel vecchio server ho installato akeeba e zippato un backup, ma senza cancellare il sito e rimetterlo, ho estratto lo zip e sovrascritto tutto ad eccezione di alcune cose tra cui ovviamente .htacess (e ricancellato il curl.php).. poi ha tutto ripreso a funzionare correttamente.
    beh, andando per esclusione sembrerebbe che proprio si siano persi dei files quando ho trasferito, e questo mi lascia un pò perplesso perchè sono piuttosto pignolo e ricordo bene di aver guardato le tab di filezilla prima di chiuderlo.. potrebbe anche essere che seppur innodb era funzionante dal pannello di altervista, in realtà non girava ancora e nell'arco di 3/4 ore ha cominciato a funzionare ed è andato tutto ok.. resterà un mistero..
    cmq ho anche aggiornato jce da pannello e tutto ha funzionato a dovere...
    grazie, ciao.

  7. #7
    L'avatar di RedWebSite
    RedWebSite non è connesso AlterGuru
    Data registrazione
    02-05-2007
    Messaggi
    1,038

    Predefinito

    ciao scusa se ti rispondo in ritardo, mi fa piacere che hai risolto, molto probabilmente quando hai trasferito il sito inizialmente senza innodb qualche tabelle non è stata scritta correttamente, o non è stata proprio scritta sul database per questo avevi problemi, comunque purtroppo joomla 3.2 ha molti problemi per questo ci sono anche ritardi nel rilascio della 3.2.1, comunque icagenda su altervista funziona perfettamente come puoi vedere anche qui è un sito di una persona del team di icagenda
    alterjoomla sito web dedicato a joomla ed altervista - Tante guide per joomla anche su RedWebSite
    "C'è una fondamentale differenza tra la religione, che è basata sull'autorità, e la scienza, che è basata su osservazione e ragionamento. E la scienza vincerà perché funziona."

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •