Pagina 2 di 2 PrimoPrimo 12
Visualizzazione risultati 31 fino 35 di 35
Like Tree1Likes

Discussione: Problema controllo accessi

  1. #31
    darbula non è connesso Utente attivo
    Data registrazione
    24-04-2011
    Messaggi
    378

    Predefinito

    Probabilmente la session_start viene chiamata dopo un output, session_start deve stare in cima a tutto anche di <html>.. Sei in grado di adattare lo script come indicato qui http://php.net/manual/en/function.session-destroy.php se si usa $_SESSION si può de registrare impostando $_SESSION=array(); con contenuto vuoto.. Uhm potresti scropire cosa non va creando un array progressivo negli if.. if($var[0]=(qui vanno le variabili)){
    qui il codice quando è vera
    }else{
    var_dump($var);
    form_login();
    }
    Ho usato la sintassi unset per farti capire quali sono le variabili di sessione in uso, quindi usale nel var_dump.
    PS. Sai perché non ti funziona il mio captcha.php? Il forum ha aggiunto &nbsp; al posto dello spazio normale.
    EDIT: in tutti e due i file è presente il bom https://it.wikipedia.org/wiki/Byte_Order_Mark se non hai un impostazione senza bom cambia editor ed ecco spiegato il puntino rosso dell'editore di gestione file
    Ultima modifica di darbula : 25-02-2017 alle ore 17.30.39

  2. #32
    Data registrazione
    13-05-2012
    Messaggi
    120

    Predefinito

    Il captcha.php l'hai modificato tu? perchè non trovo &nbsp; al posto dello spazio normale.

  3. #33
    darbula non è connesso Utente attivo
    Data registrazione
    24-04-2011
    Messaggi
    378

    Predefinito

    Non lo modificato ed ho appena provato è pieno di &nbsp; non si distingue perché sembra uno spazio normale ma invece non lo è... Fidati
    Breve spiegazione il &nbsp; nella codifica ISO-8859-1 corrisponde all esadecimale A0 mentre in UTF-8 nei esadecimali C2A0.. Dunque se quel spazio viene letto da ISO-8859-1 si vedrà Â&nbsp; (c'è sempre l'esadecimale A0)
    Ultima modifica di darbula : 25-02-2017 alle ore 23.50.39

  4. #34
    Data registrazione
    13-05-2012
    Messaggi
    120

    Predefinito

    Della serie a volte ritornano, non capisco il perchè ogni tanto si ripresentano questi problemi di accesso. Mi potete dire se fate degli aggiornamenti da altervista. Perchè non capisco come arrivano dopo qualche giorno scompaiono. Il problema è che blocco a molti utenti l'accesso. Potete aiutarmi grazie.

  5. #35
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,077

    Predefinito

    Spiega con precisione quale problema riscontri. Accesso a cosa? Visualizzi dei messaggi di errore? Quali?

Pagina 2 di 2 PrimoPrimo 12

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •