Visualizzazione risultati 1 fino 17 di 17

Discussione: https://sito.altervista.org ---> NON SICURO!!?

  1. #1
    spadanet non  connesso Neofita
    Data registrazione
    12-08-2012
    Messaggi
    12

    Exclamation https://sito.altervista.org ---> NON SICURO!!?

    Come da Oggetto il mio sito in https (risulta attivato) con joomla 2.5 viene segnalato come non sicuro
    e in formato html semplificato come risolvere!!?
    non ho cloudflare


    Ultima modifica di spadanet : 02-03-2020 alle ore 17.22.28

  2. #2
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,418

    Predefinito

    Il sito include elementi nella pagina in HTTP, rendendo quindi insicura la pagina nel complesso.
    Addirittura vengono inclusi i file CSS tramite HTTP (esempio http://spadanet.altervista.org/jooml...ss/facebox.css), quindi i browser non li caricano ed il sito viene visualizzato privo di grafica.

    Dovresti quindi impostare l'applicativo per utilizzare HTTPS.

    Ciao!

  3. #3
    spadanet non  connesso Neofita
    Data registrazione
    12-08-2012
    Messaggi
    12

    Predefinito

    Ciao
    In sintesi se nella template che uso ci sono link 'http' invece di 'https' il browser interpreta la pagina come non sicura.

  4. #4
    peppelab non  connesso Neofita
    Data registrazione
    30-06-2008
    Messaggi
    5

    Predefinito

    s, lamenta mixed content.

    non hai bisogno di indicare uno schema, basta non indicarlo affatto:

    <link href="//tuonome.altervista.org/stile.css" rel="stylesheet" type="text/css" />

  5. #5
    spadanet non  connesso Neofita
    Data registrazione
    12-08-2012
    Messaggi
    12

    Predefinito

    In effetti non avevo settato htaccess.txt e configuration.php (nella cartella Joomla)

    htaccess.txt: ho inserito le variabili dopo RewriteEngine ON ----> RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    configuration.php: public $live_site = 'https://spadanet.altervista.org/joomla/';

    Dal vostro pannello HTTPS attivo, dunque il server certificato

    Dal Pannello Joomla --> conf. globale ---> server ---> forza SSL --> entrambi (ammin. e sito)

    C'era un link del contatore inserito manualmente sulla pagina principale che ho corretto manualmente

    NONOSTANTE QUESTO la pagina non era pi visibile ne lato amministratore ne quello pubblico

    ho reimpostato tutto (dal vostro portale FTP) come prima per far riapparire il sito

    Ho cercato tutorial in merito ma non ho trovato soluzione?

  6. #6
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,418

  7. #7
    spadanet non  connesso Neofita
    Data registrazione
    12-08-2012
    Messaggi
    12

    Predefinito

    Gi Fatto, il punto ... che non riesco a rendere il sito sicuro, mi da --> contenuti misti (sicuri e non sicuri).
    Ci sono applicazioni che testano il sito e fanno una lista dello stato dei contenuti, per poterli identificare e correggere, e rendere il sito 'digeribile' dai browser principali?

  8. #8
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,418

    Predefinito

    Citazione Originalmente inviato da spadanet Visualizza messaggio
    Ci sono applicazioni che testano il sito e fanno una lista dello stato dei contenuti, per poterli identificare e correggere
    Direttamente dai principali browser, dalla console.

    Premi F12 -> Console; dovresti vedere una cosa di questo tipo.

    Ciao!

  9. #9
    spadanet non  connesso Neofita
    Data registrazione
    12-08-2012
    Messaggi
    12

    Predefinito

    Ci sono gi arrivato anche a questo, i link con http inseriti manualmente li ho gi corretti.
    Il problema sono i link generati dinamicamente da joola/Virtuemart, c' una funzione nel pannello joomla ---> force SSL ---> dove impone la modifica automatica di tutti i link da http a https.
    L'ho provato e sparisce completamente tutto il sito (non viene caricata qualsiasi pagina del sito), sia lato pubblico che amministrativo.
    Ho dovuto resettare la modifica, e tornare al setup http, solo accedendo dal FTP di Altervista, modificando force SSL da 2 a 0 come in origine.
    NON TROVO ALTRE RISORSE PER RISOLVERE, le ho provate tutte .... qualsiasi modifica da solo risultati NEGATIVI

  10. #10
    spadanet non  connesso Neofita
    Data registrazione
    12-08-2012
    Messaggi
    12

    Predefinito

    Ho anche fatto il Test del server sui certificati installati
    TEST ALTERVISTA
    E' Tutto Regolare,anche se il certificato supporta solo Browser SNI ---> MA COSA NON VA PER AGIRE SU UN SITO DINAMICO HTTP/HTTPS
    Ultima modifica di spadanet : 06-03-2020 alle ore 10.47.35

  11. #11
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,418

    Predefinito

    Con il procedimento indicato 2 risposte fa, a quanto ricordo tutti sono riusciti a risolvere con Joomla.

    Non si tratta di problemi di certificato: AlterVista eroga correttamente il certificato ed il sito in HTTPS. Il problema appunto nel configurare l'applicativo per convertire i link in HTTPS.

    Per Joomla in particolare, se non hai risolto come descritto precedentemente, dovresti chiedere nello specifico a forum pi specifici, come appunto il supporto di Joomla.

    Ciao!

  12. #12
    GDFart non  connesso Neofita
    Data registrazione
    26-10-2012
    Messaggi
    4

    Predefinito

    stavo tentando di togliere avvertimento di sito non sicuro
    ho modificato da pannello Joomla - conf. globale - server - forza SSL e mi si bloccato tutto mi esce: Impossibile raggiungere il sito La pagina web all'indirizzo https://gdfart.altervista.org/joomla/ potrebbe essere temporaneamente non disponibile oppure stata permanentemente spostata a un nuovo indirizzo web.
    ERR_SSL_UNRECOGNIZED_NAME_ALERT
    come faccio a ripristinare sito?
    aiuto!
    Ultima modifica di GDFart : 05-12-2020 alle ore 18.46.54

  13. #13
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,418

    Predefinito

    Oltre ad aver impostato Joomla a HTTPS, hai attivato HTTPS nell'account AlterVista (sul pannello di controllo)?

    Ciao!

  14. #14
    GDFart non  connesso Neofita
    Data registrazione
    26-10-2012
    Messaggi
    4

    Predefinito

    Stamattina ho attivato HTTPS da pannello Altervista risorse (mandato SMS di verifica), ma non cambiato nulla sito impossibile da raggiungere

  15. #15
    GDFart non  connesso Neofita
    Data registrazione
    26-10-2012
    Messaggi
    4

    Predefinito

    adesso mi esce : La pagina non funzionagdfart.altervista.org ti ha reindirizzato troppe volte.
    Prova a cancellare i cookie.
    ERR_TOO_MANY_REDIRECTS
    come faccio a far riapparire sito ?
    grazie

  16. #16
    GraphOGLRisorse non  connesso AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,783

    Predefinito

    Attualmente il sito risulta visibile e correttamente erogato sia in http che https.

    Citazione Originalmente inviato da GDFart Visualizza messaggio
    stavo tentando di togliere avvertimento di sito non sicuro
    ho modificato da pannello Joomla - conf. globale - server - forza SSL e mi si bloccato tutto mi esce: Impossibile raggiungere il sito La pagina web all'indirizzo https://gdfart.altervista.org/joomla/
    Se vuole effettare il redirect da http a https, aggiunga questo nell'.htaccess principale, quello presente nella root.
    Codice:
    RewriteEngine On
    RewriteBase /joomla/
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteCond %{HTTPS} off
    RewriteRule .* https://NomeSito.altervista.org%{REQUEST_URI} [L,R=301]
    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 06-12-2020 alle ore 14.30.22

  17. #17
    GDFart non  connesso Neofita
    Data registrazione
    26-10-2012
    Messaggi
    4

    Predefinito

    S adesso sono riuscito a fare funzionare tutto con anche sito che risulta sicuro, ho installato plugin Joomla come indicato qui: http://alterjoomla.altervista.org/gu...-e-joomla.html grazie a tutti !

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •