Visualizzazione risultati 1 fino 5 di 5
Like Tree2Likes
  • 1 Post By alemoppo
  • 1 Post By alemoppo

Discussione: Reindirizzamento https cloudflare non funziona

  1. #1
    marcopianta non è connesso Neofita
    Data registrazione
    25-04-2016
    Messaggi
    3

    Predefinito Reindirizzamento https cloudflare non funziona

    Buongiorno ho attivato il servizio https e cloudflare, entrambi risultano attivi.
    Ho attivato il servizio "Riscrittura automatica link HTTP" di cloudflare, ma accedendo al sito non avviene l'accesso al sito https ma solo a quello http. Come posso risolvere il problema facendo in modo che vengano sempre visualizzate solo le pagine https?

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,242

    Predefinito

    La riscrittura automatica di link è uno strumento per alcuni file inclusi nella pagina, ma non è quel che cerchi.

    Per quello che stai cercando di fare, vedi qui: Abilitare e forzare HTTPS nel proprio sito

    Ciao!
    marcopianta likes this.

  3. #3
    marcopianta non è connesso Neofita
    Data registrazione
    25-04-2016
    Messaggi
    3

    Predefinito

    Grazie mille ha funzionato, ora però ho un altro problema; quando carico la pagina (che viene correttamente caricata come https) mi esce un avviso del browser che mi dice di aver bloccato il caricamento di contenuti provenienti da fonti non sicure. Cosa può essere e come posso risolvere?

    P.S. sto usando alterpages per modificare la grafica del sito, magari può essere utile questa informazione (alterpages ho iniziato ad usarlo prima di attivare https)
    Ultima modifica di marcopianta : 13-11-2019 alle ore 23.35.52

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,242

    Predefinito

    AlterPages è un vecchio CMS che non supporta HTTPS; dovresti utilizzare un altro CMS più evoluto, come WordPress.

    In generale, il problema è che vengono inclusi contenuti in "HTTP", provocando mixed content. Se vuoi puoi modificare tutti i vari "http" in "https", ma alla prossima rigenerazione del sito ti troverai ancora i vari "http", quindi ti conviene utilizzare un CMS più recente.

    Ciao!
    marcopianta likes this.

  5. #5
    marcopianta non è connesso Neofita
    Data registrazione
    25-04-2016
    Messaggi
    3

    Predefinito

    Ok grazie mille, allora migrerò ad un nuovo CMS e rifarò tutto da capo, fortunatamente ho appena iniziato

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •