Visualizzazione risultati 1 fino 6 di 6
Like Tree1Likes
  • 1 Post By stefanodurso

Discussione: Non combaciano i file html e i file css nel server.

  1. #1
    AnimeUniversity non è connesso Neofita
    Data registrazione
    06-11-2019
    Messaggi
    3

    Predefinito Non combaciano i file html e i file css nel server.

    Buona sera,
    Io utilizzo Filezilla per caricare i miei file html e css nel server; oggi quando ho ricaricato i file aggiornati, non combaciavano i file css con i file html (il codice e' corretto), oppure, combaciavano ma, nonostante il css e' corretto, la predisposizione di testi e immagini e' errata.
    Ho provato a ricaricare di nuovo il tutto senza risultati..
    Qualcuno saprebbe darmi una mano?

  2. #2
    stefanodurso non è connesso Utente giovane
    Data registrazione
    18-10-2018
    Messaggi
    59

    Predefinito

    Svuota la cache del browser e, se lo hai attivo, anche quella di cloudflare
    AnimeUniversity likes this.

  3. #3
    AnimeUniversity non è connesso Neofita
    Data registrazione
    06-11-2019
    Messaggi
    3

    Predefinito

    Ho ripristinato tutto, ho ricaricato tutto e non cambia nulla.
    Ora per curiosità ho aperto la modalità ispeziona su chrome, e effettivamente tutti gli style e non, si sono modificati.
    ho modificato uno dei tanti file, e quando vado a caricarlo va a modificarsi come gli pare e piace.
    Io non so cosa dire ahahah.

    Dalla modalità ispeziona è possibile modificare e salvare? senza che si ripristini il tutto dopo il refresh?

    12:46
    Ora come ora ho notato sempre dalla modalità ispeziona, che nella riga stylesheet, il file viene scritto cosi "href:"LISTSAO.CSS".
    non so perchè ma il .css me lo mette in maiuscolo, e non me lo legge, per tanto ad alcune pagine manca lo style per questo motivo, anche se in fase di sviluppo è tutto scritto in minuscolo.
    -----
    Se avete consigli, io sono qua.


    14:25
    Dopo 2 giorni sono riuscito a sistemare il problema, era una svista.
    Ora ho solo un problema con un solo file css, che si modifica a caso quando lo vado a caricare nel server
    Ultima modifica di AnimeUniversity : 13-11-2019 alle ore 14.26.38

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,612

    Predefinito

    Citazione Originalmente inviato da AnimeUniversity Visualizza messaggio
    Ora ho solo un problema con un solo file css, che si modifica a caso quando lo vado a caricare nel server
    Puoi essere più specifico così da poter tentare di aiutarti?

    Ciao!

  5. #5
    AnimeUniversity non è connesso Neofita
    Data registrazione
    06-11-2019
    Messaggi
    3

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Puoi essere più specifico così da poter tentare di aiutarti?

    Ciao!
    E' proprio quello che ho scritto, mettiamo se nel file css originale c'è scritto "margin-left: 70px;" quando lo vado a caricare nel server diventa "margin-left: -50px"
    Ho potuto verificare dalla modalità ispeziona di google e se vado a correggere inserendo i reali dati,(da ispeziona) la pagina si sistema.

    Per farvi capire meglio, se aprite il mio sito web ( AnimeUniversity, non so se posso linkarlo qua, in caso mi scuso) e andate nella categoria SAO, noterete che le 4 immagini non sono centrate; se ora tornate su about e guardate il footer c'è la lingua inglese, premetela e ritornate sulla categoria SAO, li le 4 immagini sono centrate e il codice css è uguale.

    ----------------

    ok questa è bella, ho appena aperto il mio sito dal collegamento nel messaggio e le immagini sono posizionate correttamente, mentre se lo vado a cercare su google sono fuori posto
    Ultima modifica di AnimeUniversity : 14-11-2019 alle ore 11.33.14

  6. #6
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,612

    Predefinito

    Si tratta quasi certamente di qualche cache, vedi se ora il problema persiste.

    Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •