Visualizzazione risultati 1 fino 9 di 9
Like Tree1Likes
  • 1 Post By alemoppo

Discussione: problemi di sicurezza php

  1. #1
    Data registrazione
    05-11-2018
    Messaggi
    9

    Exclamation problemi di sicurezza php

    Ciao a tutti

    io ho un sito creato in joomla

    http://dragonidiavakinlife.altervista.org

    Errore
    Abbiamo rilevato che il tuo server sta utilizzando PHP 5.6.40 che è obsoleto e non riceve più aggiornamenti di sicurezza dai propri sviluppatori. Il progetto Joomla! raccommanda di aggiornare il proprio sito a PHP 7.1 o successivi, che riceveranno aggiornamenti di sicurezza almeno fino al 01-12-2019. Chiedi al tuo servizio di hosting di rendere PHP 7.1 o successive versioni predefinite per il tuo sito. Se il tuo host è già pronto per PHP 7.1 abilita PHP 7.1 nelle cartelle della root del sito e 'administrator' – di solito si può fare attraverso uno strumento del pannello di controllo dell'hosting, ma è meglio chiedere all'host se non si è sicuri.

    sul pannello di controllo io da sempre vedo questo messaggio



    e gli utenti vedono questoe non si sentono sicuri

    cosa si può fare per correggere questo errore ?


  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,237

    Predefinito

    Per quanto riguarda la versione di PHP, puoi impostare PHP7.1 da qui.

    Per quanto riguarda invece HTTPS, puoi abilitarlo da qui.

    Prima di far qualsiasi cosa, comunque, ti consiglio un backup completo dello spazio e del database. Un backup dello spazio puoi farlo facilmente da FTP. Un backup del database da phpMyAdmin.

    Ciao!

  3. #3
    Data registrazione
    05-11-2018
    Messaggi
    9

    Predefinito

    Grazie Mille Gentilissimo

  4. #4
    Data registrazione
    05-11-2018
    Messaggi
    9

    Predefinito

    salve sono di nuovo qui

    ho di nuovo un problema simile

    ora mi si presenta questo messaggio e sul pannello di controllo ho costanti problemi

    "Attenzione
    La tua versione di PHP, 7.1.26, sta ricevendo solo fix di sicurezza dal progetto PHP. Questo significa che la tua versione di PHP presto non sarà più supportata. Ti raccomandiamo di pianificare l'aggiornamento ad una versione di PHP più recente prima che raggiunga la fine del supporto il 01-12-2019. Joomla sarà più veloce e più sicuro se aggiorni ad una versione di PHP più recente. Contatta il tuo fornitore di hosting per le instruzioni su come aggiornare."

    devo fare la stessa procedura dell'altra volta ?

    Grazie in anticipo

  5. #5
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,237

    Predefinito

    Verrà rilasciato PHP 7.3 ma non so indicarti le tempistiche.

    Ciao!

  6. #6
    Data registrazione
    05-11-2018
    Messaggi
    9

    Predefinito

    Grazie Mille

  7. #7
    Data registrazione
    05-11-2018
    Messaggi
    9

    Predefinito

    non sapendo dove postare (ee sinceramente non trovo il pulsante per aprire un nuovo topic) alcune delle pagine del mio sito mi danno questo errore

    403 Forbidden

    ho cercato di fixare i permessi nel database e ho cercato se c'erano errori nel .htcaccess ma pare di no che non ci siano e nel dubbio li ho anche rimossi e fatto qualche test per poi reinserirlo ma il risultato è sempre lo stesso
    ho anche provato ad aprire quelle pagine da altri browser ma senza ottenere risposte differenti
    leggendo sul forum di joomla han detto che potrebbe anche essere un problema causato da altervista

    potete aiutarmi

  8. #8
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,237

    Predefinito

    Citazione Originalmente inviato da dragonidiavakinlife Visualizza messaggio
    non sapendo dove postare (ee sinceramente non trovo il pulsante per aprire un nuovo topic)
    Dalla homepage del forum seleziona la categoria che ti sembra più opportuna (nel tuo caso Joomla!), quindi in alto alla lista delle discussioni c'è il tasto "scrivi nuova discussione".

    In ogni caso, il tuo problema si è verificato appena installato l'applicativo o dopo aver fatto qualcosa (cosa?).
    Hai provato a modificare la versione di PHP?

    Ciao!

  9. #9
    Data registrazione
    05-11-2018
    Messaggi
    9

    Predefinito

    mmm no direi io me ne sono accorto solo di recente perche me lo hanno segnalato alcuni utenti solo in una sezione me lo fa anzi se si tenta di accedere ad una categoria specifica

    ho provato anche a ricrearla e spostare dal pannello di controllo gli articoli che erano nella categoria difettosa in quella nuova ma da cmq l'errore

    probabilmente e legato ad un dato articolo ma bisogna capire quale

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •