Visualizzazione risultati 1 fino 14 di 14

Discussione: Attivazione https - sito web sicuro - connessione protetta

  1. #1
    BozzaVisiva non è connesso Neofita
    Data registrazione
    07-03-2011
    Messaggi
    8

    Lightbulb Attivazione https - sito web sicuro - connessione protetta

    Salve, volevo delle informazioni riguardo l'attivazione al servizio https

    Ho attivato il CloudFlare, adesso vorrei attivare il servizio https
    mi chiede di inviare un codice via sms (messaggio semplice ad un numero)

    il servizio è gratuito?
    il costo equivale ad un messaggio o chi ha la promozione non consuma crediti?

    Nella barra degli indirizzi visualizzerò un "lucchetto con scritto sicuro | https:// "?

    con ovvio certificato? gratuito?

    cioè spiegatemi come funziona perchè leggo che i diversi certificati ssl si acquistano, grazie

  2. #2
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    15,527

    Predefinito

    Citazione Originalmente inviato da BozzaVisiva Visualizza messaggio
    il servizio è gratuito?
    Sì.
    Citazione Originalmente inviato da BozzaVisiva Visualizza messaggio
    il costo equivale ad un messaggio o chi ha la promozione non consuma crediti?
    Come indicato sul pannello al momento dell'operazione,
    il costo è equivalente a quello per l'invio di un sms verso un normale cellulare TIM, ed è quindi variabile a seconda del tuo operatore e dei tuoi piani tariffari o promozioni.
    Serve solo per fini di identificazione.
    Citazione Originalmente inviato da BozzaVisiva Visualizza messaggio
    Nella barra degli indirizzi visualizzerò un "lucchetto con scritto sicuro | https:// "?

    con ovvio certificato? gratuito?
    Sì, CloudFlare genererà il certificato, gratuitamente.

  3. #3
    BozzaVisiva non è connesso Neofita
    Data registrazione
    07-03-2011
    Messaggi
    8

    Predefinito

    allora sono passato in https mediante sms etc. (questo ieri sera)
    se metto https:// mio sito
    mi dice: la connessione in questo sito non è completamente protetta e non mi carica
    al contrario funziona benissimo se invece di https://mio sito metto http://

    aiuto?

  4. #4
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    15,527

  5. #5
    BozzaVisiva non è connesso Neofita
    Data registrazione
    07-03-2011
    Messaggi
    8

    Predefinito

    scusami se te lo chiedo, potresti essere più specifico
    in questo mio particolare sito
    www.bozzavisiva.altervista.org

    cosa devo modificare?
    cosa devo inserire? un meta tag?
    un codice .htacces?

    di errori me li vede come .js e questi sono brutti
    e immagini (che volendo le tolgo tutte)

  6. #6
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    15,527

    Predefinito

    Non devi togliere roba. Anzitutto, perché vuoi l'HTTPS? Hai letto i risultati della ricerca che ti ho indicato?

  7. #7
    BozzaVisiva non è connesso Neofita
    Data registrazione
    07-03-2011
    Messaggi
    8

    Predefinito

    perchè la digitatura che il browser mostra dicendomi la connessione per questo sito non è protetta non mi piace

    semplicemente questo. Ovviamente io carte di credito non le farò mettere quindi non ha senso quella digitatura

    --------
    si, ho dato uno sguardo ma non li ho capiti
    ma nel mio caso specifico come sistemo? non me lo carica l'https

  8. #8
    BozzaVisiva non è connesso Neofita
    Data registrazione
    07-03-2011
    Messaggi
    8

    Predefinito

    (se me lo puoi controllare, poi potete chiudere )

    ho trovato il difetto, era una cavolata

    ho fatto bene a crearmi questo codice basilare

    $Indirizzo="http://".$_SERVER.....
    l'ho convertito in questo
    $Indirizzo="https://".$_SERVER.....

    problema risolto ovunque


    io ho questo codice
    RewriteEngine on
    RewriteRule ^(.+)/$ [R=301,L]

    ErrorDocument 404 http://www.bozzavisiva.altervista.or...olio/error.php
    da modificare per integrare il trasferimento in https? e mantenere l'error document?

    abbiamo finito
    Ultima modifica di BozzaVisiva : 12-01-2017 alle ore 11.26.20

  9. #9
    L'avatar di darkwolf
    darkwolf non è connesso Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    5,883

    Predefinito

    Esatto. Praticamente devi far puntare ogni risorsa all'url con https invece che a quello con il semplice http.
    Né più, né meno.

    Se cerchi qui nel forum o altrove via Google trovi anche degli esempi di redirect via htaccess (così eviti i contenuti duplicati e mantieni solo una versione del sito: https).

    Saluti.

  10. #10
    BozzaVisiva non è connesso Neofita
    Data registrazione
    07-03-2011
    Messaggi
    8

    Predefinito

    RewriteEngine On
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    ErrorDocument 404 http://www.bozzavisiva.altervista.or...olio/error.php
    se volete scopiazzate
    altri tipi non funzionavano


    ora ultima cosa però voglio una risposta chiara se me lo devo stare a cercare o sistemare è brutto

    perchè sul mobile il lucchetto verde viene messo in secondo piano? o alle volte proprio oscurato
    lo riesco a vedere poco prima del caricamento pagina ma non rimane fisso

    come mai? sul browser tutto OK!

    sistemato questo chiudete,ho risolto tutto


    sistemato anche questo

  11. #11
    L'avatar di darkwolf
    darkwolf non è connesso Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    5,883

    Predefinito

    Il 404 fallo puntare direttamente all'https (eviti un inutile redirect).

  12. #12
    BozzaVisiva non è connesso Neofita
    Data registrazione
    07-03-2011
    Messaggi
    8

    Predefinito

    connessione protetta!!! finalmente, ho sistemato un pò di cose , un pò di codici e si è sbloccato!
    ora anche da mobile si vede il lucchetto

    ho solo questa attenzione : Uncaught Error: Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3

    e come mai su facebook in versione mobile https:// è la prima cosa che leggo
    mentre nel mio sito si orienta nel mezzo?
    cioè un percorso link lungo lo centra
    mentre facebook lo orienta da sinistra


    poi se si può risolvere va bene altrimenti chiudete, io sto a posto

  13. #13
    L'avatar di darkwolf
    darkwolf non è connesso Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    5,883

    Predefinito

    Ti prego di perdonarmi, ma non ho capito cosa vuoi dire.
    Si orienta nel mezzo? Che intendi?

    Io, sia nel tuo, che,nel mio, che su facebook, dal mio lumia, non noto differenze nella struttura dell'url (a livello di lucchetto e https).

    Magari fai qualche screen...

  14. #14
    BozzaVisiva non è connesso Neofita
    Data registrazione
    07-03-2011
    Messaggi
    8

    Predefinito



    .........

    sito mio da mobile


    sito facebook da mobile

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •