Visualizzazione risultati 1 fino 9 di 9

Discussione: php versione

  1. #1
    offertediscount non  connesso Neofita
    Data registrazione
    05-01-2017
    Messaggi
    9

    Predefinito php versione

    Salve,

    possibile sapere come aggiornare la versione di php?

    grazie in anticipo

  2. #2
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    15,527

  3. #3
    offertediscount non  connesso Neofita
    Data registrazione
    05-01-2017
    Messaggi
    9

    Predefinito

    si, ma non riesco a capire il meccanismo di aggiornamento

  4. #4
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    15,527

    Predefinito

    Devi modificare il file .htaccess come indicato.

  5. #5
    Data registrazione
    19-01-2016
    Messaggi
    3

    Predefinito

    Salve ragazzi ,mi associo alla discussione ,ieri ho tentato pi volte di aggiornare il mio forum phpbb da 3.1.10 alla nuova versione 3.2.0, il risultato che ottengo questo
    Girando per il web sembra che sia dovuto appunto alla versione php in uso su Altervista ( 5.3 ) mentre la nuova versione di phpbb 3.2.0 richiede il 5.4 di php.
    Nel mio pannello c' una tendina dove poter selezionare il php ,ma pur selezionando ad esempio il 5.6 non riscontro miglioramenti e continuo a non poter aggiornare il mio forum con l'errore di cui sopra .
    Consigli per poter risolvere?

  6. #6
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    15,527

    Predefinito

    Assicurati dai cambiare la versione di PHP nel file .htaccess presente nella cartella forum.

  7. #7
    Data registrazione
    19-01-2016
    Messaggi
    3

    Predefinito

    Codice:
    <IfModule mod_rewrite.c>
    RewriteEngine on
    
    #
    # Uncomment the statement below if URL rewriting doesn't
    # work properly. If you installed phpBB in a subdirectory
    # of your site, properly set the argument for the statement.
    # e.g.: if your domain is test.com and you installed phpBB
    # in http://www.test.com/phpBB/index.php you have to set
    # the statement RewriteBase /phpBB/
    #
    #RewriteBase /
    
    #
    # Uncomment the statement below if you want to make use of
    # HTTP authentication and it does not already work.
    # This could be required if you are for example using PHP via Apache CGI.
    #
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
    
    #
    # The following 3 lines will rewrite URLs passed through the front controller
    # to not require app.php in the actual URL. In other words, a controller is
    # by default accessed at /app.php/my/controller, but can also be accessed at
    # /my/controller
    #
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ app.php [QSA,L]
    
    #
    # If symbolic links are not already being followed,
    # uncomment the line below.
    # http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
    #
    #Options +FollowSymLinks
    </IfModule>
    
    # With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
    # module mod_authz_host to a new module called mod_access_compat (which may be
    # disabled) and a new "Require" syntax has been introduced to mod_authz_host.
    # We could just conditionally provide both versions, but unfortunately Apache
    # does not explicitly tell us its version if the module mod_version is not
    # available. In this case, we check for the availability of module
    # mod_authz_core (which should be on 2.4 or higher only) as a best guess.
    <IfModule mod_version.c>
    	<IfVersion < 2.4>
    		<Files "config.php">
    			Order Allow,Deny
    			Deny from All
    		</Files>
    		<Files "common.php">
    			Order Allow,Deny
    			Deny from All
    		</Files>
    	</IfVersion>
    	<IfVersion >= 2.4>
    		<Files "config.php">
    			Require all denied
    		</Files>
    		<Files "common.php">
    			Require all denied
    		</Files>
    	</IfVersion>
    </IfModule>
    <IfModule !mod_version.c>
    	<IfModule !mod_authz_core.c>
    		<Files "config.php">
    			Order Allow,Deny
    			Deny from All
    		</Files>
    		<Files "common.php">
    			Order Allow,Deny
    			Deny from All
    		</Files>
    	</IfModule>
    	<IfModule mod_authz_core.c>
    		<Files "config.php">
    			Require all denied
    		</Files>
    		<Files "common.php">
    			Require all denied
    		</Files>
    	</IfModule>
    </IfModule>
    
    # # av:php5-engine
    AddHandler av-php53 .php
    Devo cambiare il codice evidenziato in grassetto ? se si In che modo lo devo modificare? scusate ma sono proprio nubbio

  8. #8
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    15,527

    Predefinito

    Puoi eliminare quella riga (e la riga di commento immediatamente sopra quella), cos la versione di PHP impostata nella cartella padre avr effetto.

  9. #9
    Data registrazione
    19-01-2016
    Messaggi
    3

    Predefinito

    Perfetto ,adesso ci siamo , sorge per un altro problema quando vado a cliccare su "Avvia il processo di aggiornamento indirizzando il tuo browser verso la cartella di installazione." succede questo ,
    In effetti nella suddetta cartella il file index.php non c'!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •