Pagina 2 di 2 PrimoPrimo 12
Visualizzazione risultati 31 fino 43 di 43

Discussione: HTTPS: Come configurare Joomla?

  1. #31
    Guest

    Predefinito

    Ah, quella modifica nell'htaccess. come va fatta? Dove devo mettere quel testo?

  2. #32
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Vabbé, se hai risolto lascia stare quelle righe.

    Il problema adesso è il mixed content (contenuto http in pagina https).
    Ad esempio:
    Codice HTML:
    <link href="http://cdn.iabasic1.altervista.org/templates/rhuk_milkyway_ext_25/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon"/>
    da qui l'assenza della spunta verde!

    o rimuovi http: e lasci solo cdn.iabasic1.altervista.org/templates/rhuk_milkyway_ext_25/favicon.ico

    oppure modifichi i riferimenti e li fai puntare alla versione https.

    inoltre io accedo al tuo sito e rimango in http, senza essere dirottato alla versione https (quindi rischi di essere penalizzato per contenuti duplicati).

    Io ho risolto con:

    Codice PHP:
    # Force +https
    RewriteCond %{HTTPS} !on
    RewriteCond 
    %{SERVER_PORT} !^443$
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule 
    ^(.*)$ https://%{HTTP_HOST}/$1

    ### +++ Ma questo solo se vuoi anche il www:

    # Force +www
    RewriteCond %{HTTP_HOST} !^www\.
    RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L][R=301,L] 
    http://laltroweb.it/favicon.ico e/o http://www.laltroweb.it/favicon.ico > https://www.laltroweb.it/favicon.ico
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  3. #33
    Guest

    Predefinito

    Scusa... Ma non ho capito cosa devo fare. xD

  4. #34
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Scusa, mi sembrava di aver spiegato abbastanza bene, ma provo a ripetere:

    ---
    fai diventare:
    Codice HTML:
    <link href="http://cdn.iabasic1.altervista.org/templates/rhuk_milkyway_ext_25/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon"/>
    in:
    Codice HTML:
    <link href="https://cdn.iabasic1.altervista.org/templates/rhuk_milkyway_ext_25/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon"/>
    oppure:
    Codice HTML:
    <link href="//cdn.iabasic1.altervista.org/templates/rhuk_milkyway_ext_25/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon"/>
    Inoltre, per evitare contenuti duplicati, piazza una regola nell'htaccess affinché chi tutte le richiesta vengano dirottate in https.

    Poi ci sarebbero anche altre cose come l'hsts ecc, ma meglio evitare finché non sei ben sicuro di quel che fai.
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  5. #35
    Guest

    Predefinito

    Si, ma quel link come lo cambio?

  6. #36
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    iabasic: oltre a quel link ci sono anche i banner, i link interni, e tanti altri. come li cambi non lo so. devi sapere tu come li hai inseriti e quindi come correggerli. l'https non è semplicemente un click e via. devi riconfigurare l'applicativo, impostare un redirect tra la versione http a quella https, assicurarti che non ci siano fonti esterne in http che causerebbero inevitabilmente avvisi di mized content... tra l'altro non conosco joomla, e non so perché non ci sia un config dove reimpostare il link nella versione https che quindi mi sistema tutto il resto (cosa che, invece, avviene con wordpress).
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  7. #37
    Guest

    Predefinito

    https://iabasic1.altervista.org/

    Guarda non mi funziona il login e compare affianco all'indirizzo così: https://iabasic1.altervista.org/#loginModal

    Perché?

  8. #38
    Guest

    Predefinito

    Ho impostato un nuovo template che è anche responsive, Meet Gavern, ma il login in alto a destra non mi compare e nell'indirizzo si inserisce: #loginModal

    Come posso risolvere?


    Inoltre ho inserito anche il logo, l'immagine sta sul server e manco si vede...
    Ultima modifica di iabasic1 : 30-12-2016 alle ore 17.27.56

  9. #39
    Guest

    Predefinito

    ??????

  10. #40
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,632

    Predefinito

    Hai provato a chiedere supporto allo sviluppatore del template?

  11. #41
    Guest

    Predefinito

    Buongiorno a tutti ho un problema con HTTPS, non riesco ad attivarlo.
    Ho attivato CloudFlare, poi ho aspettato una quindicina di minuti, e si è attivato, ma l'HTTPS non riesco quando vado a mandare il Messaggio AV XXXXXX al numero 339 994 2899 si pianta all'invio, non è il credito o altro. Sono TIM.

  12. #42
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,632

    Predefinito

    PiketBot: apri una nuova discussione, qua si discute di altro.

  13. #43
    Guest

    Predefinito

    Come posso cambiare gli URL?

    Magari cambiare l'url dietro a quel login.

Pagina 2 di 2 PrimoPrimo 12

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •