Visualizzazione risultati 1 fino 3 di 3

Discussione: [PANNELLO] Versione PHP non viene aggiornata?

  1. #1
    socialchange non è connesso Neofita
    Data registrazione
    30-08-2013
    Messaggi
    8

    Unhappy [PANNELLO] Versione PHP non viene aggiornata?

    Ciao a tutti,

    ho provato più volte ad aggiornare la versione PHP a 5.3 ma continuo a ritrovarmi con la 5.2

    Ho verificato htaccess ed è correttamente aggiornato

    Impostazioni per la cartella / (e sottocartelle)
    PHP 5.3

    riga .htaccess
    ---------------
    # # av:php5-engine
    AddHandler av-php53 .php

    ma
    echo PHP_VERSION => 5.2.17



    cosa manca?


    Grazie!
    Giuliano
    Ultima modifica di socialchange : 28-09-2014 alle ore 18.54.39

  2. #2
    socialchange non è connesso Neofita
    Data registrazione
    30-08-2013
    Messaggi
    8

    Predefinito

    DOPO aver modificato la versione ed atteso a lungo (giorni)
    ho ripetuto l'installazione di WPress

    WPress è nella sottocartella /blog

    ho SCOPERTO
    che contiene un .htaccess che
    fa override della versione PHP

    per cui,
    malgrado l'
    /.htaccess
    contenesse la direttiva giusta,

    applicata dal PANNELLO

    WPress continuava a vedere la 5.2.17

    SOLUZIONE

    modificato manualmente
    /blog/.htaccess
    con aggiunta direttiva
    --------------------------
    # # av:php5-engine
    AddHandler av-php53 .php


    quindi, a mio avviso,
    il PANNELLO è fuorviante
    quando scrive:
    ------------------------------------
    Impostazioni per la cartella / (e sottocartelle)


    spero sia utile

    Ciao
    Giuliano

  3. #3
    L'avatar di saitfainder
    saitfainder non è connesso Sëniör Stäff
    Data registrazione
    06-12-2002
    Residenza
    Torino
    Messaggi
    8,715

    Predefinito

    Magari è un po' impreciso, ma non lo definirei fuorviante. Selezionando una versione di PHP nella cartella principale avrai quella versione in tutto il sito. Se però una sottocartella ne specifica un'altra allora tutto quello che ci sarà contenuto verrà eseguito con quell'altra versione. È un principio che si applica a tutte le impostazioni dell'htaccess.


    «È una mia peculiarità distorcere la verità e inventarne di nuove.»
    «I tuoi orientamenti hanno su di me un effetto prossimo allo zero.»


Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •