Visualizzazione risultati 1 fino 4 di 4

Discussione: CSS non funziona color

  1. #1
    albertifoto non  connesso Utente giovane
    Data registrazione
    31-03-2019
    Messaggi
    88

    Predefinito CSS non funziona color

    Sembra un problema da principianti, ma non riesco a trovare l'errore, non trova color. L'unico che trova quello che c' in "autore".
    Da notare che nel sito di prova funziona tutto, solo in quello online da il problema.
    Ho vuotato anche tutte le cache.

    Codice:
    /* Box Frase del giorno */.fraseGiorno { 
    	background-color: #f5f4f6;
    	max-width: 400px; 
    	font-family: arial;
    	color: #797979;
    	margin: 0 auto;
    	margin-top: 10px;
    	padding: 8px 10px 8px 10px;
    	border-top: 1px solid #a9a9a9;
    	border-right: 1px solid #fff;
    	border-bottom: 1px solid #fff;
    	border-left: 1px solid #a9a9a9;
    	border-radius: 20px; 
    	text-align: left;
    }  
    
    
    /* "Frase del giorno:" */
    .fraseX {
    	text-align: center;
    	color: #009193;
    }
    
    
    /* Autore frase del giorno */
    .autore {
    	font-size: 0.85em;
    	font-style: italic;	
    	color: #919191;
    	margin-top: 5px;
    }
    
    ...
    
     <div class="fraseGiorno">
        
     <div class="fraseX">Frase del giorno</div>
         
        <?php include('frasi.php'); ?> 
         
     </div><!-- fraseGiorno -->
    Questo il sito: https://albertifoto.altervista.org

  2. #2
    GraphOGLRisorse non  connesso AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,580

    Predefinito

    Salve,
    nel sito; titolo, frase e autore, risultano come link di tipo mailto. Il problema dato da come vengono gestiti i link con i css.

    Provando infatti il codice in locale, senza gestire le strinche; titolo, frase e autore come link, i colori vengono attribuiti correttamente.

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 09-01-2021 alle ore 16.10.45

  3. #3
    albertifoto non  connesso Utente giovane
    Data registrazione
    31-03-2019
    Messaggi
    88

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    Salve,
    nel sito; titolo, frase e autore, risultano come link di tipo mailto. Il problema dato da come vengono gestiti i link con i css.

    Provando infatti il codice in locale, senza gestire le strinche; titolo, frase e autore come link, i colori vengono attribuiti correttamente.

    Cordiali saluti.
    Strano, ho gli stessi file che ci sono in locale. Verifico.

  4. #4
    albertifoto non  connesso Utente giovane
    Data registrazione
    31-03-2019
    Messaggi
    88

    Predefinito

    Mancava una <a> di chiusura

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •