Visualizzazione risultati 1 fino 16 di 16
Like Tree1Likes
  • 1 Post By Gianluca

Discussione: DRUPAL - Recupero delle informazioni sugli aggiornamenti disponibili non riuscito

  1. #1
    asl02Abruzzo non è connesso Neofita
    Data registrazione
    17-10-2010
    Messaggi
    27

    Predefinito DRUPAL - Recupero delle informazioni sugli aggiornamenti disponibili non riuscito

    Da qualche tempo l'aggiornamento automatico dei moduli drupal del mio sito è impossibile. Il messaggio di errore che compare è il seguente: "Recupero delle informazioni sugli aggiornamenti disponibili non riuscito".
    Anche l'installazione dei moduli da URL fallisce con il seguente messaggio "Si è verificato l'errore HTTP 301 mentre si tentava di recuperare https://ftp.drupal.org/files/projects/ ...".

    Mi chiedevo se ciò è dovuto a Cloudflare attivo (in un altro mio sito in cui Cloudflare non è attivo gli errori non avvengono) o se magari dipende dal fatto che nella whitelist di Altervista (appena al disotto del pannello risorse/php/) non è presente l'url https//*drupal.org ma solo http://*drupal.org.

    Ciò premesso volevo chiedervi perchè accade e cosa bisogna fare per ripristinare le funzionalità suddette, vitali per tenere aggiornato un sito drupal.

    Grazie

  2. #2
    Guest

    Predefinito

    Salve,
    ho riscontrato lo stesso problema anche sul mio sito http://frenckcinema.altervista.org

    non riesco a capire il perchè dell'assenza della lista degli aggiornamenti di moduli e temi.

    Grazie

  3. #3
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    17,990

    Predefinito

    È stato inserito anche il relativo https, nel giro di 24h sarà attivo, verificate se il problema persiste
    asl02Abruzzo likes this.
    Gianluca

  4. #4
    asl02Abruzzo non è connesso Neofita
    Data registrazione
    17-10-2010
    Messaggi
    27

    Predefinito

    Comunque Cloudflare non centra nulla... infatti il problema si è presentato anche sul sito senza Cluodflare (avevo appena attivato un sito apposta per fare il test). Sarebbe interessante sapere se su altri Host la cosa non avviene (e quindi se il problema dipende da Altervista oppure dal sito degli aggiornamenti di Drupal.....).

  5. #5
    asl02Abruzzo non è connesso Neofita
    Data registrazione
    17-10-2010
    Messaggi
    27

    Predefinito

    @Gianluca grazie per aver cambiato l'https ma purtroppo non va... Confermo che il problema è solo su Altervista in quanto su altri host l'aggiornamento avviene normalmente.
    Spero l'inconveniente venga risolto al più presto.

  6. #6
    asl02Abruzzo non è connesso Neofita
    Data registrazione
    17-10-2010
    Messaggi
    27

    Predefinito

    Forse la risposta è in questo articolo http://www.pcworld.com/article/30210...ith-https.html

  7. #7
    Guest

    Predefinito

    Ragazzi credo di avere la risposta....la versione Drupal 6 da fine febbraio cesserà di essere aggiornata per dar spazio a Drupal 8, ragion per cui non ci saranno più aggiornamenti..... occorrerà quindi, per tenere sempre nuove funzionalità ed aggiornamenti al core ed ai moduli, migrare alla versione 7......cosa che mi fa rabbrividire visti i tanti forum che parlano di gravi problemi dovuti al migraggio....

  8. #8
    contentsonly non è connesso Neofita
    Data registrazione
    22-11-2014
    Messaggi
    1

    Predefinito

    Io ho drupal 7 e non funziona lo stesso. Stessi problemi già segnalati:
    "Recupero delle informazioni sugli aggiornamenti disponibili non riuscito
    installazione dei moduli da URL che non funziona "Si è verificato l'errore HTTP 301 mentre si tentava di recuperare https://ftp.drupal.org/files/projects/ ...".

  9. #9
    asl02Abruzzo non è connesso Neofita
    Data registrazione
    17-10-2010
    Messaggi
    27

    Predefinito

    Come si rileva dall'articolo che ho indicato sopra, sembrerebbe che il problema sia dovuto proprio a Drupal.org che sta cambiando il sistema degli aggiornamenti da http a connessione sicura https. Seguirà un'aggiornamento di versione che consentirà di scaricare nuovamente in automatico. Nel frattempo Drupal.org invita gli utenti a scaricare manualmente i moduli aggiornati che dovessero esser necessari. Perlomeno questo è quanto ho capito io. Quello che non mi torna è per quale motivo sull'altro Host l'aggiornamento automatico funziona... Mah!! Aspettiamo qualche giorno per eventuali sviluppi.
    NB. ma i moderatori di Altervista su tutto questo non si esprimono?
    Ultima modifica di asl02Abruzzo : 19-01-2016 alle ore 19.13.12

  10. #10
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,077

    Predefinito

    Stiamo effettuando le verifiche del caso. Potete indicare la versione di Drupal in uso attualmente sul vostro sito?

  11. #11
    asl02Abruzzo non è connesso Neofita
    Data registrazione
    17-10-2010
    Messaggi
    27

    Predefinito

    La mia versione è 7.41

  12. #12
    asl02Abruzzo non è connesso Neofita
    Data registrazione
    17-10-2010
    Messaggi
    27

    Predefinito

    Installando il modulo "chr" (https://www.drupal.org/project/chr) l'aggiornamento automatico torna a funzionare dopo qualche ora dalla installazione.

  13. #13
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,077

    Predefinito

    Quel modulo è già attivato nella versione di Drupal installabile dal pannello di controllo di AlterVista, visto che tu utilizzi una versione successiva immagino che la tua installazione sia manuale, è corretto?
    Con il modulo cURL HTTP Request vengono utilizzate le funzioni PHP cURL per effettuare le richieste esterne come quelle degli aggiornamenti, e con l'utilizzo di questo modulo non risultano problemi. Nel caso ne riscontriate segnalatelo ancora in questa discussione.
    Comunque una volta abilitato gli aggiornamenti dovrebbero riprendere a funzionare subito, hai forzato il controllo manuale degli stessi?

  14. #14
    asl02Abruzzo non è connesso Neofita
    Data registrazione
    17-10-2010
    Messaggi
    27

    Predefinito

    Si la mia installazione di Drupal era manuale e non conteneva il modulo chr che ho installato a parte manualmente. Ed è svelato anche il motivo per il quale funzionava sull'altro host.. in effetti lì ho installato da pannello di controllo e chr risulta già abilitato di default.
    Comunque mi sembra tutto chiarito a questo punto. Grazie Karl94 per l'interessamento.

  15. #15
    skywalker non è connesso Neofita
    Data registrazione
    24-08-2015
    Messaggi
    1

    Predefinito

    comfermo anch'io il problema con la versione 7.41

    la soluzione è intallare quel modulo o aspettare che drupal aggiorni i files?

    grazie
    Ultima modifica di skywalker : 26-01-2016 alle ore 17.45.31

  16. #16
    coolsoft non è connesso Utente giovane
    Data registrazione
    23-02-2005
    Messaggi
    33

    Predefinito

    Per farlo funzionare sul mio sito ho dovuto fare due modifiche:

    1) modificare al file modules/update/update.module, riga 17:
    Codice:
    define('UPDATE_DEFAULT_URL', 'http://updates.drupal.org/release-history');
    che diventa
    Codice:
    define('UPDATE_DEFAULT_URL', 'https://updates.drupal.org/release-history');
    Questo serve ad evitare il primo redirect da http://... ad https:// fatto da drupal.org e che su alcuni sistemi non funziona (ad esempio il mio sito su Altervista).

    2) installare il modulo chr ed impostarlo come default alla pagina admin/config/services/chr
    NOTA: il modulo non può essere installato direttamente tramite l'URL ma deve essere scaricato in locale e uploadato all'URL admin/modules/install

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •