Visualizzazione risultati 1 fino 28 di 28
Like Tree1Likes
  • 1 Post By coolsoft

Discussione: Drupal 8 vuole php minimo 5.4

  1. #1
    lindaiannacecreazioni non  connesso Utente AlterBlog
    Data registrazione
    15-10-2013
    Messaggi
    6

    Question Drupal 8 vuole php minimo 5.4

    Giovani geni drupalisti, a quanto pare se uno vuole installare Drupal 8 su Altervista non pu perch richiesta una versione PHP 5.4 (minimo) mentre Altervista arriva fino alla 5.3.
    Scusate la domanda da perfetto ignorante delinquenziale, ma su Altervista la versione di php si pu aggiornare oppure no?
    Cio Drupal 8 si pu installare in qualche modo o niente da fare? Non mi dite di installare Drupal 7 perch dicono che non abbia niente a che vedere con la versione 8 che molto diversa.
    Ringrazio a prescindere.

  2. #2
    Guest

    Predefinito

    Beh, Drupal 8 non ancora stato rilasciato, n c' una data certa di rilascio.
    Non ti sembra un po' presto?

  3. #3
    lindaiannacecreazioni non  connesso Utente AlterBlog
    Data registrazione
    15-10-2013
    Messaggi
    6

    Predefinito

    Hai ragione, ma vorrei provare la versione beta. Comunque mi chiedo ... quando sar rilasciata ufficialmente la versione 8 di Drupal ... Altervista aggiorner il PHP a 5.4? Chi lo sa ...

  4. #4
    Guest

    Predefinito

    Senza una data certa, il rilascio potrebbe anche avvenire tra molto tempo e magari avere gi la versione 5.4, 5.5, 6 ...
    Per le prove, puoi sempre installarti quello che vuoi sul tuo pc e fare le prove li.

  5. #5
    coolsoft non  connesso Utente giovane
    Data registrazione
    23-02-2005
    Messaggi
    33

    Predefinito

    A prescindere da Drupal 8, PHP 5.3 in quasi-end-of-life e riceve solo aggiornamenti importanti di sicurezza.
    Nessuna ottimizzazione n correzione di bug non critici.
    Basta dare un'occhiata qui: http://php.net/releases/
    PHP 5.3.27: 11 Jul 2013
    PHP 5.4.30: 26 Jun 2014

    Quindi, se la preoccupazione di AV la sicurezza ed efficienza, usare una versione cos vechia non una bella cosa.
    Basterebbe dare la 5.4 a scelta, come fu per il passaggio dalla 4 alla 5, avvisando gli utenti che la 5.4 Experimental.

    Io sono uno sviluppatore Drupal, e mantengo diversi moduli.
    Sto lavorando per portarli a Drupal8; in locale funziona tutto (ovvio) ma mi piacerebbe provarli su Altervista.

    Quindi mi associo alla richiesta: a quando PHP 5.4?

  6. #6
    L'avatar di FormularioDiDrakensang
    FormularioDiDrakensang non  connesso Altervistiano Junior
    Data registrazione
    26-04-2013
    Messaggi
    549

    Predefinito

    vedere... Php 5.4 ?

    Quindi, se la preoccupazione di AV la sicurezza ed efficienza, usare una versione cos vechia non una bella cosa.
    Basterebbe dare la 5.4 a scelta, come fu per il passaggio dalla 4 alla 5, avvisando gli utenti che la 5.4 Experimental.
    Ultima modifica di FormularioDiDrakensang : 03-08-2014 alle ore 14.35.51

  7. #7
    coolsoft non  connesso Utente giovane
    Data registrazione
    23-02-2005
    Messaggi
    33

    Predefinito

    Rilasciata la RC1 di Drupal 8, che in locale va una favola... un altro pianeta rispetto a Drupal 7.

    La situazione per Altervista per si complica ulteriormente, dato che ora non soddisfa n PHP n MySQL:
    (doc. ufficiale qui: https://www.drupal.org/requirements)
    PHP: disponibile 5.4, richiesto 5.5.9
    MySQL: disponibile 5.1.71, richiesto MySQL 5.5.3/MariaDB 5.5.20/Percona Server 5.5.8 or higher with PDO and an InnoDB

    Se per PHP la vedo dura, per MySQL la vedo ancora peggio...
    Ci sono notizie in merito a PHP 5.5 o 5.6?
    Ultima modifica di coolsoft : 08-10-2015 alle ore 22.48.33

  8. #8
    Guest

    Thumbs down

    anch'io voglio installare drupal8,in locale va bene ma lo voglio vedere online

  9. #9
    L'avatar di Gianluca
    Gianluca non  connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    17,985

    Predefinito

    gi in corso il lavoro per rendere disponibile php 5.6 (opt-in, quindi ad attivazione), cos come una versione mysql rispondente a questi requisiti, sebbene non vi sia ancora alcuna deadline in merito.
    Gianluca

  10. #10
    Guest

    Predefinito

    Citazione Originalmente inviato da Gianluca Visualizza messaggio
    gi in corso il lavoro per rendere disponibile php 5.6 (opt-in, quindi ad attivazione), cos come una versione mysql rispondente a questi requisiti, sebbene non vi sia ancora alcuna deadline in merito.
    grazie

  11. #11
    coolsoft non  connesso Utente giovane
    Data registrazione
    23-02-2005
    Messaggi
    33

    Predefinito

    La data di rilascio di D8 ora ufficiale: 19 Novembre 2015
    https://www.drupal.org/node/2605142

    Le RC sono molto promettenti, speriamo di non dover aspettare troppo per provarle on-line...

  12. #12
    coolsoft non  connesso Utente giovane
    Data registrazione
    23-02-2005
    Messaggi
    33

    Predefinito

    Citazione Originalmente inviato da Gianluca Visualizza messaggio
    sebbene non vi sia ancora alcuna deadline in merito.
    La "deadline" stata definita?
    No perch Drupal 8 stato puntualmente rilasciato il 19/11/2015, e va che un piacere...

  13. #13
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    16,390

    Predefinito

    Quando ci saranno novit in merito verranno riportate anche in questa discussione.

  14. #14
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    16,390

    Predefinito

    Coolsoft, Lindaiannacecreazioni: avete modo di provare se adesso riuscite ad installarlo?

  15. #15
    coolsoft non  connesso Utente giovane
    Data registrazione
    23-02-2005
    Messaggi
    33

    Thumbs up

    Benissimo, vedo che i requisiti ci sono:
    PHP: 5.6
    MySQL: 5.6.29

    Il mio sito ha un sacco di moduli (e diversi custom come il forum), quindi la fase di conversione sar lunga.
    Lo testerei subito, ma non posso installarlo a fianco dell'attuale Drupal 7, dato che il DB uno solo.

    E' possibile aprire un altro spazio AV con lo stesso utente?
    Oppure un account di prova/test?

  16. #16
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    16,390

    Predefinito

    Citazione Originalmente inviato da coolsoft Visualizza messaggio
    Lo testerei subito, ma non posso installarlo a fianco dell'attuale Drupal 7, dato che il DB uno solo.
    Potresti specificare un prefisso per le tabelle differente in fase di installazione.

  17. #17
    coolsoft non  connesso Utente giovane
    Data registrazione
    23-02-2005
    Messaggi
    33

    Predefinito

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    Potresti specificare un prefisso per le tabelle differente in fase di installazione.
    Si, ma dovrei portare a PHP 5.6 sia il sito in produzione (D7) che quello in prova (D8).
    Oppure possibile mettere un .htaccess in una sottocartella con una versione di PHP differente?

    UPDATE
    Ho fatto una prova ed possibile modificare la versione di PHP per una cartella (e relative sottocartelle).
    Basta aggiungerci un file .htaccess con la seguente riga (oltre alle altre necessarie per Drupal):

    Codice:
    AddHandler av-php56 .php
    ...mi metto in moto per il test
    Ultima modifica di coolsoft : 15-05-2016 alle ore 20.17.01

  18. #18
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    16,390

    Predefinito

    Citazione Originalmente inviato da coolsoft Visualizza messaggio
    Oppure possibile mettere un .htaccess in una sottocartella con una versione di PHP differente?
    S, le impostazioni dei file .htaccess sono valide solo per la cartella specifica e le sottocartelle.

  19. #19
    Guest

    Predefinito

    io non riesco,mi esce questo messaggio:

    Messaggio di errore Risolvere tutti i problemi elencati per continuare
    l'installazione. Per ottenere aiuto sulla
    configurazione del database manuale di
    installazione, oppure contattare il proprio fornitore
    di servizi web.
    Il server MySQL e il driver PHP MySQL devono
    supportare la codifica caratteri utf8mb4.
    Assicurati di utilizzare un sistema di database
    che la supporti (come
    MySQL/MariaDB/Percona 5.5.3 e superiore), e
    che sia compilato con il supporto per il set di
    caratteri utf8mb4. Leggi la documentazione
    MySQL per ulteriori informazioni.
    La versione del database 5.1.71-community-
    log inferiore a quella richiesta: 5.5.3.

  20. #20
    L'avatar di darkwolf
    darkwolf non  connesso Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    5,966

    Predefinito

    Ti sta dicendo che il tuo sito ha mysql 5.1.71-*, non 5.5.3 (come richiesto da drupal 8).
    In effetti, anche io vedo che c' il mysql 5.1: http://darkwolf.altervista.org/_ips4.php > http://darkwolf.altervista.org/_ips4.php?phpinfo
    e quindi i requisiti non sono sufficienti.
    Ultima modifica di darkwolf : 16-05-2016 alle ore 15.38.56

  21. #21
    Guest

    Predefinito

    Citazione Originalmente inviato da darkwolf Visualizza messaggio
    Ti sta dicendo che il tuo sito ha mysql 5.1.71-*, non 5.5.3 (come richiesto da drupal 8).
    In effetti, anche io vedo che c' il mysql 5.1: http://darkwolf.altervista.org/_ips4.php > http://darkwolf.altervista.org/_ips4.php?phpinfo
    e quindi i requisiti non sono sufficienti.
    questo che non capisco,dato che ho scelto dal menu a tendina, nella cartella dove ho drupal otto,il php 5.6

  22. #22
    L'avatar di darkwolf
    darkwolf non  connesso Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    5,966

    Predefinito

    Ma, infatti, dal phpinfo: http://darkwolf.altervista.org/_ips4.php?phpinfo
    si evince che il php 5.6 effettivamente presente. Il problema il database mysql a non essere "almeno" 5.5.3

    Un utente poco prima, per, parlava di mysql 5.6.29 ... Magari stato abilitato per alcuni siti, al momento, e pian piano lo abiliteranno anche negli altri.
    Ultima modifica di darkwolf : 16-05-2016 alle ore 15.56.37

  23. #23
    coolsoft non  connesso Utente giovane
    Data registrazione
    23-02-2005
    Messaggi
    33

    Predefinito

    Citazione Originalmente inviato da darkwolf Visualizza messaggio
    Ma, infatti, dal phpinfo: http://darkwolf.altervista.org/_ips4.php?phpinfo
    si evince che il php 5.6 effettivamente presente. Il problema il database mysql a non essere "almeno" 5.5.3

    Un utente poco prima, per, parlava di mysql 5.6.29 ... Magari stato abilitato per alcuni siti, al momento, e pian piano lo abiliteranno anche negli altri.
    La versione di MySQL l'ho vista nel phpMyAdmin, accessibile dal pannello di controllo.
    Pu darsi che non tutti i server abbiano la stessa versione.
    darkwolf likes this.

  24. #24
    L'avatar di darkwolf
    darkwolf non  connesso Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    5,966

  25. #25
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    16,390

    Predefinito

    ruggero0912: riprova adesso.
    La nuova versione di MySQL adesso disponibile per i nuovi account.

  26. #26
    rainnic non  connesso Neofita
    Data registrazione
    14-05-2012
    Messaggi
    7

    Predefinito

    Anche io non riesco ad installare Drupal 8, a causa della versione del database di MySQL (5.1.71-community-log anzich la 5.5.3). Ho anche provato ad usare SQLite ma mi ritorna un "Errore 500" e andando a leggere il log mi ritrovo questo:
    Warning: touch(): Utime failed: Operation not permitted in Drupal\Component\PhpStorage\MTimeProtectedFastFile Storage->save() (line 98 of core/lib/Drupal/Component/PhpStorage/MTimeProtectedFastFileStorage.php).
    Drupal\Component\PhpStorage\MTimeProtectedFastFile Storage->save('0cdf8ca8_html.html.twig_ea8c8eb3336f228a12b 69792bf84cddfbcc1c2b83e5800dd6c7f4e1f54f68fa0', '<?php [...]

  27. #27
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    16,390

    Predefinito

    Citazione Originalmente inviato da rainnic Visualizza messaggio
    Anche io non riesco ad installare Drupal 8, a causa della versione del database di MySQL (5.1.71-community-log anzich la 5.5.3). Ho anche provato ad usare SQLite ma mi ritorna un "Errore 500" e andando a leggere il log mi ritrovo questo:
    Leggi Installazione Drupal 8.x

  28. #28
    rainnic non  connesso Neofita
    Data registrazione
    14-05-2012
    Messaggi
    7

    Predefinito

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    Si grazie ho risolto con le 2 patch del thread. Resta al momento l'odiato "Errore 500" quando metto la lingua italiana nell'installazione iniziale e scelgo la versione "Standard", ma credo che si possa ovviare in una fase successiva.

    Aggiornamento: Drupal 8 riesco ad installarlo in "inglese" e in versione "Minimal" con il database SQLite, ma quando provo ad installare nuovi moduli mi esce l'errore qui sotto e non ne vuole proprio sapere di continuare ad accedere alla pagina "Extend".
    The website encountered an unexpected error. Please try again later.
    Ultima modifica di rainnic : 30-06-2016 alle ore 17.39.37

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •