Visualizzazione risultati 1 fino 5 di 5

Discussione: problema con mybb e sql

  1. #1
    kiastinger non è connesso Neofita
    Data registrazione
    07-04-2018
    Messaggi
    4

    Predefinito problema con mybb e sql

    Buonasera ragazzi ho un problema con mybb su altervista
    quando provo ad installare plugin ricevo l errore:
    myBB has experienced an internal SQL error and cannot continue.

    SQL Error:
    1366 - Incorrect integer value: '' for column 'sid' at row 1

    mi e capitato con piu plugin come posso risolvere ? grazie

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,833

    Predefinito

    Strano, prima fai un backup completo. Da phpmyadmin prova ad impostare un valore di default al campo "sid": cerca una tabella (da struttura) con una colonna sid, ed imposta un valore predefinito.

    Ciao!

  3. #3
    kiastinger non è connesso Neofita
    Data registrazione
    07-04-2018
    Messaggi
    4

    Predefinito

    ciao grazie per la risposta , scusa l ingoranza ho cercato la struttura sid ma ne compaiono piu di una , continuo a ricevere l errore
    MyBB has experienced an internal SQL error and cannot continue.

    SQL Error:
    1366 - Incorrect integer value: '' for column 'sid' at row 1
    Query:
    INSERT INTO mybb_settings (`sid`,`name`,`title`,`description`,`optionscode`, `value`,`disporder`,`gid`) VALUES ('','myadvertisements_disabled','Advertisements disabled?','Set to yes if you want to disable all advertisements.','yesno',0,1,36)

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,833

    Predefinito

    Ok, il problema è che il codice sta tentando di inserire un '' in un campo riservato ai numeri. Se riesci ad accedere alla query, prova a renderla così:

    Codice:
    INSERT INTO mybb_settings (`name`,`title`,`description`,`optionscode`, `value`,`disporder`,`gid`) VALUES ('myadvertisements_disabled','Advertisements disabled?','Set to yes if you want to disable all advertisements.','yesno',0,1,36)
    Ciao!
    Ultima modifica di alemoppo : 27-04-2018 alle ore 14.42.58

  5. #5
    kiastinger non è connesso Neofita
    Data registrazione
    07-04-2018
    Messaggi
    4

    Predefinito

    grazie ho risolto cambiando nel file php le voci sid da "null" a 0 cosi l installazione ha avuto successo

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •