Visualizzazione risultati 1 fino 8 di 8

Discussione: https non funziona

  1. #1
    clima non è connesso Neofita
    Data registrazione
    03-12-2017
    Messaggi
    18

    Predefinito https non funziona

    Ciao riscrivo per precisare che ho attivato HTTPS e CloudFlare prima di scrivere tutto il sito sono passati mesi ma non c'è stata alcuna conversione da http a https ... vorrei il sito in https come posso fare?Credo sia un problema di altervista.

    Grazie ciao Jaro

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,833

    Predefinito

    Il tuo sito è correttamente visibile in https: https://clima.altervista.org/

    Come ti ho scritto nell'altra discussione, o dovresti passare a wordpress oppure puoi forzare l'https anche quando il sito è visualizzato in http.

    Per forzarlo in https potresti inserire nell'.htaccess questo codice:

    Codice:
    # BEGIN AV_HTTPS
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteCond %{HTTPS} off
    RewriteRule .* https://clima.altervista.org%{REQUEST_URI} [L,R=301]
    # END AV_HTTPS
    Ciao!

  3. #3
    clima non è connesso Neofita
    Data registrazione
    03-12-2017
    Messaggi
    18

    Predefinito

    grazieeeeeeeeeeeeeeeee mille scusa se non ho letto prima una settimana di vacanza

    posso provare WordPress e se non mi ritrovo tornare ad alter?

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,833

    Predefinito

    Se provi wordpress attivato dal pannello alterVista il tuo account verrà trasformato in "alterBlog", quindi con differenti caratteristiche. Per tornare ad alterSito dovrai eliminare l'account e ri-iscriverti.

    Se vuoi provare alterBlog, ti consiglierei di usare un nuovo account e provare da lì. Se dovesse soddisfarti allora potrai convertire il tuo attuale.

    Puoi anche provare wordpress originale (da wordpress.org) in questo caso il tuo account rimarrà alterSito.

    Ciao!

  5. #5
    clima non è connesso Neofita
    Data registrazione
    03-12-2017
    Messaggi
    18

    Predefinito

    ciao grazie per la risposta ho altre due domande:

    la 1 ho visualizzato il mio sito su https per appare a destra della barra di ricerca di chrome uno scudo biano e nero con una quadrato rosso con una x che la pagina sta caricando script non sicuri se acconsento sulla barra di ricerca sparisce la scritta verde sicuro per lasciare il posto alla scritta rossa non sicura.... poco rassicurante perchè ?


    la 2 non capisco la seconda parte della risposta cioè in che senso wordpress originale lo scarico e lo uso sul mio sito ?

    porta pazienza ma sono imbranato su queste cose ancora grazie e Ciao

  6. #6
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,833

    Predefinito

    1) Il tuo sito ha elementi inclusi in http, da "ispeziona" del browser, si vede infatti:


    Dovresti includere tutti gli elementi in https, altrimenti è vero che la pagina sorgente si apre in https, ma avendo elementi in http il browser dirà comunque che la pagina non è sicura (per approfondimenti, cerca "mixed content").

    2) Wordpress è un CMS, come qualsiasi CMS installabile per conto tuo sullo spazio alterVista. Se però non sai bene cosa stai facendo, ti consiglierei di usare wordpress fornito da alterVista (AlterBlog): avrai tutto configurato automaticamente (ricordo che per tornare indietro dovrai eliminare l'account e quindi ri-iscrivere l'account).

    Ciao!

  7. #7
    clima non è connesso Neofita
    Data registrazione
    03-12-2017
    Messaggi
    18

    Predefinito

    grazie Aleppo

    Come faccio ad includere tutti gli elementi?

    Grazie mille ciao jaro

  8. #8
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,833

    Predefinito

    Siccome alterPages era stato pensato non in https, ci sono gli elementi nel file "style.css":
    @import url('http://fonts.googleapis.com/css?family=Lora:400,400italic,700,700italic');
    @import url('http://fonts.googleapis.com/css?family=Montserrat:400,400italic,700,700italic' );
    @import url('http://fonts.googleapis.com/css?family=Montserrat:400,400italic,700,700italic' );
    La soluzione più facile è usare wordpress.

    Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •